summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--01-change-filename-tags-for-directories.patch21
-rw-r--r--02-fix-configure.patch20
-rw-r--r--03-custom-rbl.patch17
-rw-r--r--04-fix-missing-include.patch12
-rw-r--r--PKGBUILD51
6 files changed, 148 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..256ef06c3380
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Tue Aug 22 01:21:34 UTC 2017
+pkgbase = rblcheck
+ pkgdesc = Tool to query RBL servers
+ pkgver = 1.5
+ pkgrel = 3
+ url = https://github.com/logic/rblcheck
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = glibc
+ depends = bash
+ backup = etc/rblcheckrc
+ source = git+https://github.com/logic/rblcheck.git#tag=rblcheck-1.5
+ source = 01-change-filename-tags-for-directories.patch
+ source = 02-fix-configure.patch
+ source = 03-custom-rbl.patch
+ source = 04-fix-missing-include.patch
+ md5sums = SKIP
+ md5sums = 9e8ed44f4bc6abf235a14065b6aa373c
+ md5sums = ef71fccbf229eafc7ff6df57de2511ea
+ md5sums = a9bc3e8a9b13adc20dfc40052a3ab367
+ md5sums = ccc95fb87a4192d4a0ddb36cd5df0a36
+
+pkgname = rblcheck
+
diff --git a/01-change-filename-tags-for-directories.patch b/01-change-filename-tags-for-directories.patch
new file mode 100644
index 000000000000..0a5674c33e15
--- /dev/null
+++ b/01-change-filename-tags-for-directories.patch
@@ -0,0 +1,21 @@
+--- a/docs/rblcheck.sgml (revision 71)
++++ b/docs/rblcheck.sgml (revision 72)
+@@ -160,7 +160,7 @@
+ <Para>
+ When you are done, you can type <Application>make install</Application> to
+ install the software (by default, everything will be installed in
+-<Filename>/usr/local</Filename>.
++<Filename class="directory">/usr/local</Filename>.
+ </Para>
+
+ <Para>
+@@ -397,7 +397,8 @@
+ A recent addition to the rblcheck package is the <Application>rbl</Application>
+ shell script, which is a simple wrapper around rblcheck, with one special
+ feature: it will read a global <Filename>rblcheckrc</Filename> (usually
+-in <Filename>/etc</Filename> or <Filename>/usr/etc</Filename>), and then
++in <Filename class="directory">/etc</Filename> or
++<Filename class="directory">/usr/etc</Filename>), and then
+ a <Filename>.rblcheckrc</Filename> from the current user's home directory.
+ These files can contain any of the usual <Application>rblcheck</Application>
+ command-line arguments (see <XRef linkend="using_rblcheck">), but are most
diff --git a/02-fix-configure.patch b/02-fix-configure.patch
new file mode 100644
index 000000000000..3f059b9c5430
--- /dev/null
+++ b/02-fix-configure.patch
@@ -0,0 +1,20 @@
+# Copyright 2015 Séastien Luttringer
+--- a/configure.in 2015-09-18 02:55:59.825544232 +0200
++++ b/configure.in 2015-09-18 03:23:33.544191972 +0200
+@@ -19,15 +19,7 @@
+ dnl Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
+
+-dnl Figure out where to get res_query from. First, see if it's in the
+-dnl C library (Linux, and probably a few others). Then, check libbind
+-dnl (generally, if you've installed bind 8, you're going to want to use
+-dnl the new library). Finally, check for libresolv (which should exist
+-dnl on most systems).
+-AC_CHECK_FUNC(res_query,,
+- AC_CHECK_LIB(resolv,res_query,,
+- AC_CHECK_LIB(bind,res_query,,
+- AC_MSG_ERROR(cannot locate res_query function))))
++AC_CHECK_LIB(resolv, __res_query)
+
+ dnl All done.
+ AC_OUTPUT(Makefile docs/Makefile config/rblcheck.spec config/pkginfo)
diff --git a/03-custom-rbl.patch b/03-custom-rbl.patch
new file mode 100644
index 000000000000..c8ef44157234
--- /dev/null
+++ b/03-custom-rbl.patch
@@ -0,0 +1,17 @@
+--- a/sites.h
++++ b/sites.h
+@@ -62,3 +62,14 @@
+ /* ORDB: Open Relay DataBase
+ http://www.ordb.org/ */
+ /* SITE("relays.ordb.org") */
++
++
++SITE("zen.spamhaus.org");
++SITE("sbl.spamhaus.org");
++SITE("xbl.spamhaus.org");
++SITE("pbl.spamhaus.org");
++SITE("bl.spamcop.net");
++SITE("psbl.surriel.com");
++SITE("dnsbl.njabl.org");
++SITE("dnsbl.sorbs.net");
++
diff --git a/04-fix-missing-include.patch b/04-fix-missing-include.patch
new file mode 100644
index 000000000000..e9fc32a5df14
--- /dev/null
+++ b/04-fix-missing-include.patch
@@ -0,0 +1,12 @@
+# Copyright © Sébastien Luttringer
+--- a/rblcheck.c 2012-06-23 20:11:05.508352459 +0200
++++ b/rblcheck.c 2014-03-27 02:20:45.286918851 +0100
+@@ -30,6 +30,8 @@
+ #include <arpa/nameser.h>
+ #include <resolv.h>
+ #include <netdb.h>
++#include <unistd.h>
++#include <stdlib.h>
+
+ /*-- PORTABILITY ------------------------------------------------------------*/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..338f61155fe3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# $Id: PKGBUILD 207393 2017-01-14 18:17:11Z seblu $
+# Maintainer: Sébastien Luttringer <seblu@archlinux.org>
+
+pkgname=rblcheck
+pkgver=1.5
+pkgrel=3
+pkgdesc='Tool to query RBL servers'
+arch=('i686' 'x86_64')
+url='https://github.com/logic/rblcheck'
+license=('GPL2')
+depends=('glibc' 'bash')
+makedepends=('git')
+backup=('etc/rblcheckrc')
+source=("git+https://github.com/logic/rblcheck.git#tag=rblcheck-$pkgver"
+ '01-change-filename-tags-for-directories.patch'
+ '02-fix-configure.patch'
+ '03-custom-rbl.patch'
+ '04-fix-missing-include.patch')
+md5sums=('SKIP'
+ '9e8ed44f4bc6abf235a14065b6aa373c'
+ 'ef71fccbf229eafc7ff6df57de2511ea'
+ 'a9bc3e8a9b13adc20dfc40052a3ab367'
+ 'ccc95fb87a4192d4a0ddb36cd5df0a36')
+
+prepare() {
+ cd $pkgname
+ # apply patch from the source array (should be a pacman feature)
+ local filename
+ for filename in "${source[@]}"; do
+ if [[ "$filename" =~ \.patch$ ]]; then
+ msg2 "Applying patch ${filename##*/}"
+ patch -p1 -N -i "$srcdir/${filename##*/}"
+ fi
+ done
+ :
+}
+
+build() {
+ cd $pkgname
+ ./bootstrap
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
+ install -Dm 644 /dev/null "$pkgdir/etc/rblcheckrc"
+}
+
+# vim:set ts=2 sw=2 et: