summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f79c9e60a21a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = redstore
+ pkgdesc = RedStore is a lightweight RDF triplestore written in C using the Redland library.
+ pkgver = 0.5.4
+ pkgrel = 1
+ url = http://www.aelius.com/njh/redstore/
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ depends = rasqal>=0.9.27
+ depends = redland>=1.0.14
+ depends = raptor>=2.0.4
+ options = !libtool
+ source = http://www.aelius.com/njh/redstore/redstore-0.5.4.tar.gz
+ md5sums = 5857c99d0aaf384050ea17e15354feba
+
+pkgname = redstore
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e994a2b19aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=redstore
+pkgver=0.5.4
+pkgrel=1
+pkgdesc="RedStore is a lightweight RDF triplestore written in C using the Redland library."
+arch=('i686' 'x86_64')
+url="http://www.aelius.com/njh/redstore/"
+depends=('rasqal>=0.9.27' 'redland>=1.0.14' 'raptor>=2.0.4')
+license=('GPLv3')
+options=('!libtool')
+source=(http://www.aelius.com/njh/redstore/$pkgname-$pkgver.tar.gz)
+md5sums=('5857c99d0aaf384050ea17e15354feba')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make prefix=${pkgdir}/usr install
+}
+