summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD29
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31cc49955a6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = reflow-git
+ pkgdesc = Route any network connection to proxies with flexible rules
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/net-reflow/reflow
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = cargo-nightly
+ makedepends = git
+ provides = reflow
+ conflicts = reflow
+ source = reflow-git::git+https://github.com/net-reflow/reflow
+ sha1sums = SKIP
+
+pkgname = reflow-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21b6fd69ba41
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: leafly <leafly@tuta.io>
+pkgname=reflow-git
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Route any network connection to proxies with flexible rules"
+arch=('i686' 'x86_64' 'aarch64')
+url="https://github.com/net-reflow/reflow"
+license=('GPL3')
+provides=("reflow")
+makedepends=('cargo-nightly' 'git')
+conflicts=('reflow')
+source=("$pkgname::git+https://github.com/net-reflow/reflow")
+sha1sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+ if command -v rustup > /dev/null 2>&1; then
+ rustup run nightly \
+ cargo build --release
+ else
+ cargo build --release
+ fi
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 "target/release/reflow" "$pkgdir/usr/bin/reflow"
+ install -Dm644 "README.md" "$pkgdir/usr/share/doc/${pkgname}/README.md"
+}