summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD40
-rw-r--r--regoth.install14
3 files changed, 41 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7677496ff37..d5eb41c52c83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,29 @@
# Generated by mksrcinfo v8
-# Fri Feb 1 20:17:51 UTC 2019
+# Sat Oct 12 23:42:00 UTC 2019
pkgbase = regoth-git
- pkgdesc = OpenSource-Reimplementation of the zEngine, used by the game 'Gothic'
- pkgver = 0.4.357.r1599.65c72f0
+ pkgdesc = Reimplementation of Gothic I and II using modern technologies.
+ pkgver = r533.e080948
pkgrel = 1
- url = https://github.com/REGoth-project/REGoth
+ url = https://regoth-project.github.io/REGoth-bs
install = regoth.install
arch = i686
arch = x86_64
- license = GPLv3
+ license = MIT
makedepends = git
makedepends = cmake
- depends = gcc>=6
+ depends = physfs
+ depends = libx11
+ depends = libxcursor
+ depends = libxi
+ depends = icu
+ depends = mesa
+ depends = freeglut
+ depends = libxrandr
+ optdepends = doxygen: for documentation
+ optdepends = plantuml: for documentation
provides = regoth
conflicts = regoth
- source = regoth-git::git+https://github.com/REGoth-project/REGoth.git
+ source = regoth-git::git+https://github.com/REGoth-project/REGoth-bs.git
md5sums = SKIP
pkgname = regoth-git
diff --git a/PKGBUILD b/PKGBUILD
index e0e5d7aa1e91..b4961b5b1685 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,20 @@
# Maintainer: aksr <aksr at t-com dot me>
pkgname=regoth-git
-pkgver=0.4.357.r1599.65c72f0
+pkgver=r533.e080948
pkgrel=1
epoch=
-pkgdesc="OpenSource-Reimplementation of the zEngine, used by the game 'Gothic'"
+pkgdesc="Reimplementation of Gothic I and II using modern technologies."
arch=('i686' 'x86_64')
-url="https://github.com/REGoth-project/REGoth"
-license=('GPLv3')
+url="https://github.com/REGoth-project/REGoth-bs"
+url="https://regoth-project.github.io/REGoth-bs"
+license=('MIT')
categories=()
groups=()
depends=('gcc>=6')
+depends=(physfs libx11 libxcursor libxi icu mesa freeglut libxrandr)
makedepends=('git' 'cmake')
-optdepends=()
+optdepends=('doxygen: for documentation'
+ 'plantuml: for documentation')
checkdepends=()
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
@@ -20,34 +23,37 @@ backup=()
options=()
changelog=
install="${pkgname%-*}".install
-source=("$pkgname::git+https://github.com/REGoth-project/REGoth.git")
+source=("$pkgname::git+https://github.com/REGoth-project/REGoth-bs.git")
noextract=()
md5sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
- printf "%s.r%s.%s" "$(git describe --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/^nightly.//')" \
- "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build() {
+prepare() {
cd "$srcdir/$pkgname"
git submodule update --init --recursive
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ rm -rf build
mkdir build
cd build
- cmake -DCMAKE_BUILD_TYPE=Release ..
- make -j$(grep -c ^processor /proc/cpuinfo)
+ cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo ..
+ cmake --build . --parallel $(nproc)
}
package() {
cd "$srcdir/$pkgname/build/bin"
- mkdir -p $pkgdir/usr/{bin,share/${pkgname%-*}/}
- for i in altonegen makehrtf openal-info REGoth write_sf2; do
- install -Dm755 $i "$pkgdir/usr/share/${pkgname%-*}/$i"
+ mkdir -p $pkgdir/usr/{bin,lib}
+ for i in *; do
+ install -Dm755 $i "$pkgdir/usr/bin/$i"
done
- ln -rs $pkgdir/usr/share/${pkgname%-*}/REGoth $pkgdir/usr/bin/REGoth
- cp -r shaders $pkgdir/usr/share/${pkgname%-*}/
+ cp -r ../lib/lib* $pkgdir/usr/lib
install -Dm644 ../../README.md $pkgdir/usr/share/doc/${pkgname%-*}/README.md
- install -Dm644 ../../LICENSE.md $pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE
+ install -Dm644 ../../LICENSE $pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE
}
diff --git a/regoth.install b/regoth.install
index 1abf0a3aacbe..619ac90de90e 100644
--- a/regoth.install
+++ b/regoth.install
@@ -1,15 +1,5 @@
post_install(){
- echo "==> Running"
- echo " REGoth -g "path/to/gothic1or2" -w startworld.zen"
- echo " Additionally, for a list of possible commands, run REGoth --help."
- echo "==> Examples"
- echo " Gothic 1 - Overworld: REGoth -g "path/to/gothic1" -w world.zen"
- echo " Gothic 1 - Oldmine: REGoth -g "path/to/gothic1" -w oldmine.zen"
- echo " Gothic 1 - Freemine: REGoth -g "path/to/gothic1" -w freemine.zen"
- echo " Gothic 1 - Sleeper temple: REGoth -g "path/to/gothic1" -w orctemple.zen"
- echo " Gothic 2 - Overworld: REGoth -g "path/to/gothic2" -w newworld.zen"
- echo " Gothic 2 - Valley of mines: REGoth -g "path/to/gothic2" -w oldworld.zen"
- echo " Gothic 2 - Addonworld: REGoth -g "path/to/gothic2" -w addonworld.zen"
- echo " Gothic 2 - Dragonisland: REGoth -g "path/to/gothic2" -w dragonisland.zen"
+ echo "==> More info:"
+ echo " https://regoth-project.github.io/REGoth-bs/getting-started/running.html"
}