summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD4
-rw-r--r--patch.diff30
3 files changed, 16 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f06a79483c54..87bf65e429a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = regripper-git
pkgdesc = RegRipper is an open source forensic software used as a Windows Registry data extraction command line or GUI tool.
- pkgver = r15.9f2a96a
+ pkgver = r60.5d104c4
pkgrel = 2
url = https://github.com/keydet89/RegRipper3.0
arch = any
@@ -11,7 +11,6 @@ pkgbase = regripper-git
source = regripper-git::git+https://github.com/keydet89/RegRipper3.0
source = patch.diff
sha256sums = SKIP
- sha256sums = b1c590c5ec4e42fb920f7d4089c8acac7cda6d4dbef265ca78ba7bfff4d5118c
+ sha256sums = 36a64f4887cd71da9b01956b3c3c4574a3b77164914a660aea44e002a8a79a04
pkgname = regripper-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 15bb619c5d8d..7f9a29229c32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# RegRipper
pkgname=regripper-git
-pkgver=r15.9f2a96a
+pkgver=r60.5d104c4
pkgrel=2
pkgdesc="RegRipper is an open source forensic software used as a Windows Registry data extraction command line or GUI tool."
arch=('any')
@@ -13,7 +13,7 @@ options=('!emptydirs')
source=("$pkgname::git+https://github.com/keydet89/RegRipper3.0"
"patch.diff")
sha256sums=('SKIP'
- 'b1c590c5ec4e42fb920f7d4089c8acac7cda6d4dbef265ca78ba7bfff4d5118c')
+ '36a64f4887cd71da9b01956b3c3c4574a3b77164914a660aea44e002a8a79a04')
pkgver() {
cd "$pkgname"
diff --git a/patch.diff b/patch.diff
index a7a940286fc3..91fce857cbec 100644
--- a/patch.diff
+++ b/patch.diff
@@ -1,5 +1,7 @@
-diff --git a/rip.pl b/rip.pl
-index a8045b0..6682a68 100644
+diff--git a/rip.pl b/rip.pl
+old mode 100644
+new mode 100755
+index 59dfcbe..ecc4f14
--- a/rip.pl
+++ b/rip.pl
@@ -1,4 +1,4 @@
@@ -8,19 +10,11 @@ index a8045b0..6682a68 100644
#-------------------------------------------------------------------------
# Rip - RegRipper, CLI version
# Use this utility to run a plugins file or a single plugin against a Reg
-@@ -65,7 +65,7 @@ $str =~ s/($path[scalar(@path) - 1])//;
- # code updated 20190318
- my $plugindir;
- ($^O eq "MSWin32") ? ($plugindir = $str."plugins/")
-- : ($plugindir = File::Spec->catfile("plugins"));
-+ : ($plugindir = File::Spec->catfile("/usr/share/regripper/plugins"));
- #my $plugindir = $str."plugins/";
- #my $plugindir = File::Spec->catfile("plugins");
- #print "Plugins Dir = ".$plugindir."\n";
-@@ -557,4 +557,4 @@ sub getDateFromEpoch {
- my ($sec,$min,$hour,$mday,$mon,$year) = gmtime($epoch);
- my $fmt = sprintf("%04d-%02d-%02d %02d:%02d:%02d",(1900 + $year),($mon + 1),$mday,$hour,$min,$sec);
- return $fmt;
--}
-\ No newline at end of file
-+}
+@@ -57,6 +57,8 @@ my %config;
+ Getopt::Long::Configure("prefix_pattern=(-|\/)");
+ GetOptions(\%config,qw(reg|r=s file|f=s csv|c dirty|d auto|a autoTLN|aT guess|g user|u=s sys|s=s plugin|p=s update|uP list|l help|?|h));
+
++my $plugindir = "/usr/share/regripper/plugins/";
++
+ # Retrieves absolute path to executable
+ my $scriptpath = Cwd::realpath($0);