summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22783949f83a..46d6eb2acf09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
-pkgbase = reicast-git
- pkgdesc = A multiplatform Sega Dreamcast emulator (development version)
+pkgbase = reicast-c1-git
+ pkgdesc = A multiplatform Sega Dreamcast emulator for ODROID-C1 (development version)
pkgver = r1284.d3c3feb
pkgrel = 1
url = http://reicast.com/
- arch = i686
- arch = x86_64
+ arch = armv7h
license = GPL2
license = BSD
license = MIT
@@ -13,8 +12,9 @@ pkgbase = reicast-git
depends = alsa-lib
provides = reicast
conflicts = reicast
+ conflicts = reicast-git
source = reicast::git+https://github.com/reicast/reicast-emulator.git
md5sums = SKIP
-pkgname = reicast-git
+pkgname = reicast-c1-git
diff --git a/PKGBUILD b/PKGBUILD
index f4510f28c847..a354a8957b55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
-pkgname=reicast-git
+pkgname=reicast-c1-git
pkgver=r1284.d3c3feb
pkgrel=1
-pkgdesc="A multiplatform Sega Dreamcast emulator (development version)"
-arch=('i686' 'x86_64')
+pkgdesc="A multiplatform Sega Dreamcast emulator for ODROID-C1 (development version)"
+arch=('armv7h')
url="http://reicast.com/"
license=('GPL2' 'BSD' 'MIT')
-conflicts=('reicast')
+conflicts=('reicast' 'reicast-git')
provides=('reicast')
makedepends=('git')
depends=('libgl' 'alsa-lib')
@@ -20,6 +20,9 @@ pkgver() {
}
build () {
+ MALI_INCLUDE="$srcdir/c1_mali_libs/fbdev/mali_headers"
+ export CFLAGS="-I$MALI_INCLUDE"
+ export LDFLAGS+=" -L/usr/lib/mali-egl -L/usr/lib/aml_libs"
make -C reicast/shell/linux
}