summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
2 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c392db62319..ee7466785033 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = remotely
- pkgdesc = A GTK3 VNC Client
+ pkgdesc = simple VNC viewer for the GNOME desktop environment
pkgver = 1.0
- pkgrel = 1
- url = https://gitlab.gnome.org/haecker-felix/Remotely
+ pkgrel = 2
+ url = https://gitlab.gnome.org/World/Remotely
arch = i686
arch = x86_64
- arch = armv6h
arch = armv7h
+ arch = aarch64
license = GPL3
makedepends = meson
makedepends = vala
depends = gtk-vnc
source = https://gitlab.gnome.org/World/Remotely/-/archive/v1.0/Remotely-v1.0.tar.gz
- md5sums = 35b9d43f36fbb743de7b8819f0981d10
+ sha256sums = d4f849388dcecc0f1206d6a8ec897b92239149861334327d45145d699ffdbaf8
pkgname = remotely
diff --git a/PKGBUILD b/PKGBUILD
index d3193fd71245..a2e0aef7f765 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
pkgname=remotely
pkgver=1.0
-pkgrel=1
-pkgdesc="A GTK3 VNC Client"
-arch=('i686' 'x86_64' 'armv6h' 'armv7h')
-url="https://gitlab.gnome.org/haecker-felix/Remotely"
-license=('GPL3')
-depends=('gtk-vnc')
-makedepends=('meson' 'vala')
+pkgrel=2
+pkgdesc="simple VNC viewer for the GNOME desktop environment"
+arch=(i686 x86_64 armv7h aarch64)
+url="https://gitlab.gnome.org/World/Remotely"
+license=(GPL3)
+depends=(gtk-vnc)
+makedepends=(meson vala)
source=("https://gitlab.gnome.org/World/Remotely/-/archive/v${pkgver}/Remotely-v${pkgver}.tar.gz")
-md5sums=('35b9d43f36fbb743de7b8819f0981d10')
+sha256sums=('d4f849388dcecc0f1206d6a8ec897b92239149861334327d45145d699ffdbaf8')
build() {
@@ -18,6 +18,10 @@ build() {
ninja -C build
}
+check() {
+ meson test -C build --print-errorlogs
+}
+
package() {
- DESTDIR="$pkgdir/" ninja -C build install
+ DESTDIR="$pkgdir" meson install -C build
}