summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD34
3 files changed, 36 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6664a8ef465..277d580b2b88 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,24 @@
pkgbase = rescached-git
pkgdesc = Resolver/DNS cache daemon
- pkgver = 4.3.0.r0.g36b08fe
+ pkgver = 4.4.2.r9.gd35cf24
pkgrel = 1
- url = https://github.com/shuLhan/rescached-go
+ url = https://git.sr.ht/~shulhan/rescached
install = rescached.install
arch = i686
arch = x86_64
arch = armv7h
- license = custom:BSD
+ license = GPL-3.0-or-later
makedepends = git
- makedepends = go>=1.16
+ makedepends = go>=1.20
depends = bash
provides = rescached
+ backup = etc/rescached/block.d/.pgl.yoyo.org
+ backup = etc/rescached/block.d/.someonewhocares.org
+ backup = etc/rescached/block.d/.winhelp2002.mvps.org
backup = etc/rescached/rescached.cfg
- backup = etc/rescached/localhost.cert.pem
- backup = etc/rescached/localhost.key.pem
- source = rescached-git::git+https://github.com/shuLhan/rescached-go.git
+ backup = etc/rescached/localhost.pem
+ backup = etc/rescached/localhost.pem.key
+ source = rescached-git::git+https://git.sr.ht/~shulhan/rescached
sha1sums = SKIP
pkgname = rescached-git
diff --git a/.gitignore b/.gitignore
index 71f2839d63a5..feb2a8f86310 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1,8 @@
-libvos/
-pkg/
-rescached-git/
-src/
*.tar
*.xz
*.zst
+/libvos/
+/pkg/
+/rescached-local/
+/rescached-git/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
index 900bc1150099..9a25fd1426ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,48 @@
# Maintainer: shulhan <ms@kilabit.info>
pkgname=rescached-git
-pkgver=4.3.0.r0.g36b08fe
+pkgver=4.4.2.r9.gd35cf24
pkgrel=1
pkgdesc="Resolver/DNS cache daemon"
arch=('i686' 'x86_64' 'armv7h')
-url="https://github.com/shuLhan/rescached-go"
-license=('custom:BSD')
+url="https://git.sr.ht/~shulhan/rescached"
+license=('GPL-3.0-or-later')
depends=('bash')
provides=('rescached')
-makedepends=('git' 'go>=1.16')
+makedepends=('git' 'go>=1.20')
+_sourcedir=$pkgname
source=(
- "$pkgname::git+https://github.com/shuLhan/rescached-go.git"
- ## For testing on local.
- #"$pkgname::git+file:///home/ms/go/src/github.com/shuLhan/rescached-go"
+ "$pkgname::git+https://git.sr.ht/~shulhan/rescached"
)
+## For testing on local.
+#_sourcedir=rescached-local
+#source=(
+# "$_sourcedir::git+file:///home/ms/go/src/git.sr.ht/~shulhan/rescached#branch=dev"
+#)
+
sha1sums=(
'SKIP'
)
backup=(
+ 'etc/rescached/block.d/.pgl.yoyo.org'
+ 'etc/rescached/block.d/.someonewhocares.org'
+ 'etc/rescached/block.d/.winhelp2002.mvps.org'
'etc/rescached/rescached.cfg'
- 'etc/rescached/localhost.cert.pem'
- 'etc/rescached/localhost.key.pem'
+ 'etc/rescached/localhost.pem'
+ 'etc/rescached/localhost.pem.key'
)
install=rescached.install
pkgver() {
- cd "$pkgname"
+ cd "$_sourcedir"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$pkgname"
+ cd "$_sourcedir"
echo ">>"
echo ">> cleaning ..."
echo ">>"
@@ -43,12 +51,12 @@ build() {
echo ">> make ..."
echo ">>"
unset GOROOT
- export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
make || return 1
}
package() {
- cd "$pkgname"
+ cd "$_sourcedir"
make PREFIX="$pkgdir" install
rm -rf ${pkgdir}/usr/share/rescached/
install -Dm644 $srcdir/$pkgname/COPYING \