summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD45
-rw-r--r--rescached-git.install14
4 files changed, 45 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 835a88a360c8..ebfe829b1dc1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,23 @@
pkgbase = rescached-git
pkgdesc = Resolver/DNS cache daemon
- pkgver = 1.1.0.r0.g6be6500
+ pkgver = 20160904
pkgrel = 1
url = https://github.com/shuLhan/rescached
+ install = rescached-git.install
arch = i686
arch = x86_64
- license = GPL3
+ license = custom:BSD
makedepends = git
makedepends = asciidoc
- depends = glibc
+ depends = gcc-libs
provides = rescached
- conflicts = rescached
+ conflicts = bind
+ conflicts = nsd
+ conflicts = pdnsd
+ conflicts = powerdns
+ conflicts = unbound
backup = etc/rescached/rescached.cfg
- source = rescached::git+https://github.com/shuLhan/rescached.git
+ source = rescached-git::git+https://github.com/shuLhan/rescached.git
source = libvos::git+https://github.com/shuLhan/libvos.git
sha1sums = SKIP
sha1sums = SKIP
diff --git a/.gitignore b/.gitignore
index 0e4f1a62b6f0..7ef4e8d28065 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,5 @@ libvos/
pkg/
rescached/
src/
+*.tar
*.xz
diff --git a/PKGBUILD b/PKGBUILD
index e815095f4055..361fb7b1862e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,36 @@
-# Maintainer: sulhan <ms at kilabit.info>
-_pkgname=rescached
+# Maintainer: sulhan <ms@kilabit.info>
pkgname=rescached-git
-pkgver=1.1.0.r0.g6be6500
+pkgver=1.2.0.r0.gbadfe94
pkgrel=1
pkgdesc="Resolver/DNS cache daemon"
arch=('i686' 'x86_64')
url="https://github.com/shuLhan/rescached"
-license=('GPL3')
-depends=('glibc')
-makedepends=('git' 'asciidoc')
+license=('custom:BSD')
+
+depends=('gcc-libs')
provides=('rescached')
-conflicts=('rescached')
-backup=('etc/rescached/rescached.cfg')
+conflicts=('bind' 'nsd' 'pdnsd' 'powerdns' 'unbound')
+
+makedepends=('git' 'asciidoc')
source=(
- "$_pkgname::git+https://github.com/shuLhan/rescached.git"
+ "$pkgname::git+https://github.com/shuLhan/rescached.git"
"libvos::git+https://github.com/shuLhan/libvos.git"
)
sha1sums=(
- 'SKIP'
- 'SKIP'
+ 'SKIP'
+ 'SKIP'
)
+install=rescached-git.install
+backup=('etc/rescached/rescached.cfg')
+
pkgver() {
- cd "$srcdir/$_pkgname/src"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
prepare() {
- cd "$srcdir/$_pkgname"
+ cd "$pkgname"
git submodule init
git config submodule.libvos.url $srcdir/libvos
git submodule update
@@ -35,7 +38,7 @@ prepare() {
}
build() {
- cd "$srcdir/$_pkgname/src"
+ cd "$pkgname/src"
echo ">>"
echo ">> cleaning ..."
echo ">>"
@@ -48,15 +51,7 @@ build() {
}
package() {
- cd "$srcdir/$_pkgname/src"
-
+ cd "$pkgname/src"
make DESTDIR="$pkgdir/" install
-
- install -D -m644 $srcdir/$_pkgname/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-
-post_install() {
- [[ -f /etc/rescached/hosts.ads ]] && rm -f /etc/rescached/hosts.ads
-}
-
-# vim:set ts=2 sw=2:
diff --git a/rescached-git.install b/rescached-git.install
new file mode 100644
index 000000000000..e932c8877999
--- /dev/null
+++ b/rescached-git.install
@@ -0,0 +1,14 @@
+post_upgrade() {
+ ## Remove old ads file
+ [[ -f /etc/rescached/hosts.ads ]] \
+ && rm -f /etc/rescached/hosts.ads
+
+ ## Fix wrong systemd service
+ [[ -f /etc/systemd/system/rescached.service ]] \
+ && rm -f /etc/systemd/system/rescached.service
+
+ systemctl daemon-reload
+
+ echo ':: rescached service now installed in /usr/lib/systemd/system'
+ echo ':: Please reenable the service if you want to start it at boot'
+}