summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--00-fix-missing-cstdint.patch228
-rw-r--r--00-fix-missing-limits.patch125
-rw-r--r--01-use-yaramod-v3.21.0.patch18
-rw-r--r--PKGBUILD16
5 files changed, 264 insertions, 129 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5037a3fd0c2..f4bbfde78ee3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = retdec
pkgdesc = A retargetable machine-code decompiler based on LLVM
pkgver = 5.0
- pkgrel = 1
+ pkgrel = 2
url = https://retdec.com/
arch = x86_64
license = MIT
@@ -14,6 +14,10 @@ pkgbase = retdec
optdepends = upx: To use UPX unpacker in the preprocessing stage
optdepends = graphviz: To generate call or control flow grpahs
source = https://github.com/avast/retdec/archive/refs/tags/v5.0.tar.gz
+ source = 00-fix-missing-cstdint.patch
+ source = 01-use-yaramod-v3.21.0.patch
sha256sums = 216dc62fd54ff06277497492dbf44bc7a91e39249d8aefdee2e4f10fc903ce85
+ sha256sums = 4e4cd25fc540b45985d5b670c41de88edac3af2efd0b708a6c83b561b23631dc
+ sha256sums = d461f420b23fe00669c24c82d94de97b8caffde84ad164ed47f19e77348c55e3
pkgname = retdec
diff --git a/00-fix-missing-cstdint.patch b/00-fix-missing-cstdint.patch
new file mode 100644
index 000000000000..397bc4c8872b
--- /dev/null
+++ b/00-fix-missing-cstdint.patch
@@ -0,0 +1,228 @@
+diff --git a/include/retdec/ctypes/enum_type.h b/include/retdec/ctypes/enum_type.h
+index ecd6f33..a586938 100644
+--- a/include/retdec/ctypes/enum_type.h
++++ b/include/retdec/ctypes/enum_type.h
+@@ -7,6 +7,7 @@
+ #ifndef RETDEC_CTYPES_ENUM_TYPE_H
+ #define RETDEC_CTYPES_ENUM_TYPE_H
+
++#include <cstdint>
+ #include <memory>
+ #include <string>
+ #include <vector>
+diff --git a/include/retdec/fileformat/types/dotnet_headers/metadata_header.h b/include/retdec/fileformat/types/dotnet_headers/metadata_header.h
+index 8645fab..57d8af6 100644
+--- a/include/retdec/fileformat/types/dotnet_headers/metadata_header.h
++++ b/include/retdec/fileformat/types/dotnet_headers/metadata_header.h
+@@ -7,6 +7,7 @@
+ #ifndef RETDEC_FILEFORMAT_TYPES_DOTNET_HEADERS_METADATA_HEADER_H
+ #define RETDEC_FILEFORMAT_TYPES_DOTNET_HEADERS_METADATA_HEADER_H
+
++#include <cstdint>
+ #include <string>
+
+ namespace retdec {
+diff --git a/include/retdec/fileformat/types/dotnet_headers/metadata_table.h b/include/retdec/fileformat/types/dotnet_headers/metadata_table.h
+index 31be818..3e9d8c2 100644
+--- a/include/retdec/fileformat/types/dotnet_headers/metadata_table.h
++++ b/include/retdec/fileformat/types/dotnet_headers/metadata_table.h
+@@ -7,6 +7,7 @@
+ #ifndef RETDEC_FILEFORMAT_TYPES_DOTNET_HEADERS_METADATA_TABLE_H
+ #define RETDEC_FILEFORMAT_TYPES_DOTNET_HEADERS_METADATA_TABLE_H
+
++#include <cstdint>
+ #include <string>
+ #include <vector>
+
+diff --git a/include/retdec/fileformat/types/export_table/export.h b/include/retdec/fileformat/types/export_table/export.h
+index 85c1e35..f891a5b 100644
+--- a/include/retdec/fileformat/types/export_table/export.h
++++ b/include/retdec/fileformat/types/export_table/export.h
+@@ -7,6 +7,7 @@
+ #ifndef RETDEC_FILEFORMAT_TYPES_EXPORT_TABLE_EXPORT_H
+ #define RETDEC_FILEFORMAT_TYPES_EXPORT_TABLE_EXPORT_H
+
++#include <cstdint>
+ #include <string>
+
+ namespace retdec {
+diff --git a/include/retdec/fileformat/types/import_table/import.h b/include/retdec/fileformat/types/import_table/import.h
+index a527e24..fcc70cf 100644
+--- a/include/retdec/fileformat/types/import_table/import.h
++++ b/include/retdec/fileformat/types/import_table/import.h
+@@ -7,6 +7,7 @@
+ #ifndef RETDEC_FILEFORMAT_TYPES_IMPORT_TABLE_IMPORT_H
+ #define RETDEC_FILEFORMAT_TYPES_IMPORT_TABLE_IMPORT_H
+
++#include <cstdint>
+ #include <string>
+
+ namespace retdec {
+diff --git a/include/retdec/fileformat/types/relocation_table/relocation.h b/include/retdec/fileformat/types/relocation_table/relocation.h
+index 617f81d..f2579a4 100644
+--- a/include/retdec/fileformat/types/relocation_table/relocation.h
++++ b/include/retdec/fileformat/types/relocation_table/relocation.h
+@@ -7,6 +7,7 @@
+ #ifndef RETDEC_FILEFORMAT_TYPES_RELOCATION_TABLE_RELOCATION_H
+ #define RETDEC_FILEFORMAT_TYPES_RELOCATION_TABLE_RELOCATION_H
+
++#include <cstdint>
+ #include <string>
+ #include <vector>
+
+diff --git a/include/retdec/fileformat/types/rich_header/linker_info.h b/include/retdec/fileformat/types/rich_header/linker_info.h
+index 2c281f2..543957e 100644
+--- a/include/retdec/fileformat/types/rich_header/linker_info.h
++++ b/include/retdec/fileformat/types/rich_header/linker_info.h
+@@ -7,6 +7,7 @@
+ #ifndef RETDEC_FILEFORMAT_TYPES_RICH_HEADER_LINKER_INFO_H
+ #define RETDEC_FILEFORMAT_TYPES_RICH_HEADER_LINKER_INFO_H
+
++#include <cstdint>
+ #include <string>
+
+ namespace retdec {
+diff --git a/include/retdec/fileformat/types/rich_header/rich_header.h b/include/retdec/fileformat/types/rich_header/rich_header.h
+index e3c60dd..0b77627 100644
+--- a/include/retdec/fileformat/types/rich_header/rich_header.h
++++ b/include/retdec/fileformat/types/rich_header/rich_header.h
+@@ -7,6 +7,7 @@
+ #ifndef RETDEC_FILEFORMAT_TYPES_RICH_HEADER_RICH_HEADER_H
+ #define RETDEC_FILEFORMAT_TYPES_RICH_HEADER_RICH_HEADER_H
+
++#include <cstdint>
+ #include <string>
+ #include <vector>
+
+diff --git a/include/retdec/fileformat/types/strings/string.h b/include/retdec/fileformat/types/strings/string.h
+index a89d848..fbe67e2 100644
+--- a/include/retdec/fileformat/types/strings/string.h
++++ b/include/retdec/fileformat/types/strings/string.h
+@@ -7,6 +7,7 @@
+ #ifndef RETDEC_FILEFORMAT_TYPES_STRINGS_STRING_H
+ #define RETDEC_FILEFORMAT_TYPES_STRINGS_STRING_H
+
++#include <cstdint>
+ #include <string>
+
+ namespace retdec {
+diff --git a/include/retdec/fileformat/types/tls_info/tls_info.h b/include/retdec/fileformat/types/tls_info/tls_info.h
+index 6b091c6..668b927 100644
+--- a/include/retdec/fileformat/types/tls_info/tls_info.h
++++ b/include/retdec/fileformat/types/tls_info/tls_info.h
+@@ -7,6 +7,7 @@
+ #ifndef RETDEC_FILEFORMAT_TYPES_TLS_INFO_TLS_INFO_H
+ #define RETDEC_FILEFORMAT_TYPES_TLS_INFO_TLS_INFO_H
+
++#include <cstdint>
+ #include <string>
+ #include <vector>
+
+diff --git a/include/retdec/fileformat/utils/byte_array_buffer.h b/include/retdec/fileformat/utils/byte_array_buffer.h
+index eae0d4f..aeec585 100644
+--- a/include/retdec/fileformat/utils/byte_array_buffer.h
++++ b/include/retdec/fileformat/utils/byte_array_buffer.h
+@@ -7,6 +7,7 @@
+ #ifndef RETDEC_FILEFORMAT_UTILS_BYTE_ARRAY_BUFFER_H
+ #define RETDEC_FILEFORMAT_UTILS_BYTE_ARRAY_BUFFER_H
+
++#include <cstdint>
+ #include <streambuf>
+
+ namespace retdec {
+diff --git a/include/retdec/pdbparser/pdb_utils.h b/include/retdec/pdbparser/pdb_utils.h
+index 459f609..4f30696 100644
+--- a/include/retdec/pdbparser/pdb_utils.h
++++ b/include/retdec/pdbparser/pdb_utils.h
+@@ -7,6 +7,7 @@
+ #ifndef RETDEC_PDBPARSER_PDB_UTILS_H
+ #define RETDEC_PDBPARSER_PDB_UTILS_H
+
++#include <cstdint>
+ #include <map>
+ #include <string>
+ #include <vector>
+diff --git a/include/retdec/utils/conversion.h b/include/retdec/utils/conversion.h
+index 371e8c9..e34b27b 100644
+--- a/include/retdec/utils/conversion.h
++++ b/include/retdec/utils/conversion.h
+@@ -7,6 +7,7 @@
+ #ifndef RETDEC_UTILS_CONVERSION_H
+ #define RETDEC_UTILS_CONVERSION_H
+
++#include <cstdint>
+ #include <iomanip>
+ #include <ios>
+ #include <limits>
+diff --git a/include/retdec/utils/file_io.h b/include/retdec/utils/file_io.h
+index ff9ca0d..b4d61f8 100644
+--- a/include/retdec/utils/file_io.h
++++ b/include/retdec/utils/file_io.h
+@@ -7,6 +7,7 @@
+ #ifndef RETDEC_UTILS_FILE_IO_H
+ #define RETDEC_UTILS_FILE_IO_H
+
++#include <cstdint>
+ #include <fstream>
+ #include <vector>
+
+diff --git a/include/retdec/utils/string.h b/include/retdec/utils/string.h
+index 7461889..2eb9d77 100644
+--- a/include/retdec/utils/string.h
++++ b/include/retdec/utils/string.h
+@@ -8,6 +8,7 @@
+ #define RETDEC_UTILS_STRING_H
+
+ #include <algorithm>
++#include <cstdint>
+ #include <limits>
+ #include <map>
+ #include <string>
+diff --git a/include/retdec/yaracpp/yara_meta.h b/include/retdec/yaracpp/yara_meta.h
+index 8084064..1589c2d 100644
+--- a/include/retdec/yaracpp/yara_meta.h
++++ b/include/retdec/yaracpp/yara_meta.h
+@@ -7,6 +7,7 @@
+ #ifndef RETDEC_YARACPP_YARA_META_H
+ #define RETDEC_YARACPP_YARA_META_H
+
++#include <cstdint>
+ #include <string>
+
+ namespace retdec {
+diff --git a/src/fileinfo/file_information/file_information_types/elf_core.h b/src/fileinfo/file_information/file_information_types/elf_core.h
+index 19a262e..0170bd0 100644
+--- a/src/fileinfo/file_information/file_information_types/elf_core.h
++++ b/src/fileinfo/file_information/file_information_types/elf_core.h
+@@ -7,6 +7,7 @@
+ #ifndef FILEINFO_FILE_INFORMATION_FILE_INFORMATION_TYPES_ELF_CORE_H
+ #define FILEINFO_FILE_INFORMATION_FILE_INFORMATION_TYPES_ELF_CORE_H
+
++#include <cstdint>
+ #include <string>
+ #include <vector>
+
+diff --git a/src/pat2yara/logic.h b/src/pat2yara/logic.h
+index 737c5e5..de603c5 100644
+--- a/src/pat2yara/logic.h
++++ b/src/pat2yara/logic.h
+@@ -7,6 +7,7 @@
+ #ifndef PAT2YARA_LOGIC_H
+ #define PAT2YARA_LOGIC_H
+
++#include <cstdint>
+ #include <memory>
+ #include <string>
+
+diff --git a/src/unpackertool/arg_handler.h b/src/unpackertool/arg_handler.h
+index ae3a884..2ca0c4a 100644
+--- a/src/unpackertool/arg_handler.h
++++ b/src/unpackertool/arg_handler.h
+@@ -7,6 +7,7 @@
+ #ifndef UNPACKERTOOL_ARG_HANDLER_H
+ #define UNPACKERTOOL_ARG_HANDLER_H
+
++#include <cstdint>
+ #include <map>
+ #include <string>
+ #include <vector>
diff --git a/00-fix-missing-limits.patch b/00-fix-missing-limits.patch
deleted file mode 100644
index 13620859eeb2..000000000000
--- a/00-fix-missing-limits.patch
+++ /dev/null
@@ -1,125 +0,0 @@
-diff --git a/src/fileinfo/file_information/file_information_types/data_directory.h b/src/fileinfo/file_information/file_information_types/data_directory.h
-index e14e37de..3e3d7b21 100644
---- a/src/fileinfo/file_information/file_information_types/data_directory.h
-+++ b/src/fileinfo/file_information/file_information_types/data_directory.h
-@@ -7,6 +7,7 @@
- #ifndef FILEINFO_FILE_INFORMATION_FILE_INFORMATION_TYPES_DATA_DIRECTORY_H
- #define FILEINFO_FILE_INFORMATION_FILE_INFORMATION_TYPES_DATA_DIRECTORY_H
-
-+#include <limits>
- #include <string>
-
- namespace retdec {
-diff --git a/src/fileinfo/file_information/file_information_types/dynamic_section/dynamic_entry.h b/src/fileinfo/file_information/file_information_types/dynamic_section/dynamic_entry.h
-index 9c880914..044e96a9 100644
---- a/src/fileinfo/file_information/file_information_types/dynamic_section/dynamic_entry.h
-+++ b/src/fileinfo/file_information/file_information_types/dynamic_section/dynamic_entry.h
-@@ -9,6 +9,8 @@
-
- #include "fileinfo/file_information/file_information_types/flags.h"
-
-+#include <limits>
-+
- namespace retdec {
- namespace fileinfo {
-
-diff --git a/src/fileinfo/file_information/file_information_types/file_header.h b/src/fileinfo/file_information/file_information_types/file_header.h
-index fb3444d4..fe635122 100644
---- a/src/fileinfo/file_information/file_information_types/file_header.h
-+++ b/src/fileinfo/file_information/file_information_types/file_header.h
-@@ -7,6 +7,8 @@
- #ifndef FILEINFO_FILE_INFORMATION_FILE_INFORMATION_TYPES_FILE_HEADER_H
- #define FILEINFO_FILE_INFORMATION_FILE_INFORMATION_TYPES_FILE_HEADER_H
-
-+#include <limits>
-+
- #include "fileinfo/file_information/file_information_types/flags.h"
-
- namespace retdec {
-diff --git a/src/fileinfo/file_information/file_information_types/file_section.h b/src/fileinfo/file_information/file_information_types/file_section.h
-index d9aed57a..4e024196 100644
---- a/src/fileinfo/file_information/file_information_types/file_section.h
-+++ b/src/fileinfo/file_information/file_information_types/file_section.h
-@@ -7,6 +7,8 @@
- #ifndef FILEINFO_FILE_INFORMATION_FILE_INFORMATION_TYPES_FILE_SECTION_H
- #define FILEINFO_FILE_INFORMATION_FILE_INFORMATION_TYPES_FILE_SECTION_H
-
-+#include <limits>
-+
- #include "fileinfo/file_information/file_information_types/flags.h"
-
- namespace retdec {
-diff --git a/src/fileinfo/file_information/file_information_types/file_segment.h b/src/fileinfo/file_information/file_information_types/file_segment.h
-index a4ea70e8..b187c3b0 100644
---- a/src/fileinfo/file_information/file_information_types/file_segment.h
-+++ b/src/fileinfo/file_information/file_information_types/file_segment.h
-@@ -7,6 +7,8 @@
- #ifndef FILEINFO_FILE_INFORMATION_FILE_INFORMATION_TYPES_FILE_SEGMENT_H
- #define FILEINFO_FILE_INFORMATION_FILE_INFORMATION_TYPES_FILE_SEGMENT_H
-
-+#include <limits>
-+
- #include "fileinfo/file_information/file_information_types/flags.h"
-
- namespace retdec {
-diff --git a/src/fileinfo/file_information/file_information_types/pattern/pattern_match.h b/src/fileinfo/file_information/file_information_types/pattern/pattern_match.h
-index 98017760..23d716ff 100644
---- a/src/fileinfo/file_information/file_information_types/pattern/pattern_match.h
-+++ b/src/fileinfo/file_information/file_information_types/pattern/pattern_match.h
-@@ -7,6 +7,8 @@
- #ifndef FILEINFO_FILE_INFORMATION_FILE_INFORMATION_TYPES_PATTERN_PATTERN_MATCH_H
- #define FILEINFO_FILE_INFORMATION_FILE_INFORMATION_TYPES_PATTERN_PATTERN_MATCH_H
-
-+#include <limits>
-+
- namespace retdec {
- namespace fileinfo {
-
-diff --git a/src/fileinfo/file_information/file_information_types/pdb_info.h b/src/fileinfo/file_information/file_information_types/pdb_info.h
-index d78a346c..73f0647c 100644
---- a/src/fileinfo/file_information/file_information_types/pdb_info.h
-+++ b/src/fileinfo/file_information/file_information_types/pdb_info.h
-@@ -7,6 +7,7 @@
- #ifndef FILEINFO_FILE_INFORMATION_FILE_INFORMATION_TYPES_PDB_INFO_H
- #define FILEINFO_FILE_INFORMATION_FILE_INFORMATION_TYPES_PDB_INFO_H
-
-+#include <limits>
- #include <string>
-
- namespace retdec {
-diff --git a/src/fileinfo/file_information/file_information_types/relocation_table/relocation.h b/src/fileinfo/file_information/file_information_types/relocation_table/relocation.h
-index a773524f..8700564b 100644
---- a/src/fileinfo/file_information/file_information_types/relocation_table/relocation.h
-+++ b/src/fileinfo/file_information/file_information_types/relocation_table/relocation.h
-@@ -7,6 +7,7 @@
- #ifndef FILEINFO_FILE_INFORMATION_FILE_INFORMATION_TYPES_RELOCATION_TABLE_RELOCATION_H
- #define FILEINFO_FILE_INFORMATION_FILE_INFORMATION_TYPES_RELOCATION_TABLE_RELOCATION_H
-
-+#include <limits>
- #include <string>
-
- namespace retdec {
-diff --git a/src/fileinfo/file_information/file_information_types/resource_table/resource.h b/src/fileinfo/file_information/file_information_types/resource_table/resource.h
-index d3299843..35752442 100644
---- a/src/fileinfo/file_information/file_information_types/resource_table/resource.h
-+++ b/src/fileinfo/file_information/file_information_types/resource_table/resource.h
-@@ -7,6 +7,7 @@
- #ifndef FILEINFO_FILE_INFORMATION_FILE_INFORMATION_TYPES_RESOURCE_TABLE_RESOURCE_H
- #define FILEINFO_FILE_INFORMATION_FILE_INFORMATION_TYPES_RESOURCE_TABLE_RESOURCE_H
-
-+#include <limits>
- #include <string>
-
- namespace retdec {
-diff --git a/src/fileinfo/file_information/file_information_types/symbol_table/symbol.h b/src/fileinfo/file_information/file_information_types/symbol_table/symbol.h
-index 0acc90d5..e650a4a0 100644
---- a/src/fileinfo/file_information/file_information_types/symbol_table/symbol.h
-+++ b/src/fileinfo/file_information/file_information_types/symbol_table/symbol.h
-@@ -7,6 +7,7 @@
- #ifndef FILEINFO_FILE_INFORMATION_FILE_INFORMATION_TYPES_SYMBOL_TABLE_SYMBOL_H
- #define FILEINFO_FILE_INFORMATION_FILE_INFORMATION_TYPES_SYMBOL_TABLE_SYMBOL_H
-
-+#include <limits>
- #include <string>
-
- namespace retdec {
diff --git a/01-use-yaramod-v3.21.0.patch b/01-use-yaramod-v3.21.0.patch
new file mode 100644
index 000000000000..20d67e4237a7
--- /dev/null
+++ b/01-use-yaramod-v3.21.0.patch
@@ -0,0 +1,18 @@
+diff --git a/cmake/deps.cmake b/cmake/deps.cmake
+index cd6668a..b6b6f5b 100644
+--- a/cmake/deps.cmake
++++ b/cmake/deps.cmake
+@@ -45,11 +45,11 @@ set(YARA_ARCHIVE_SHA256
+ )
+
+ set(YARAMOD_URL
+- "https://github.com/avast/yaramod/archive/a367d910ae79698e64e99d8414695281723cd34b.zip"
++ "https://github.com/avast/yaramod/archive/b183632d6c61c1957f818167adbb1570ba885819.zip"
+ CACHE STRING "URL of YaraMod archive to use."
+ )
+ set(YARAMOD_ARCHIVE_SHA256
+- "2d2dc60890ad9b796fb908162bd3968b8ada693ab2b08e55cdd1c359c643b72b"
++ "b9c7298ef93ffec46bdfdf7b377f55c9a3c949a7742c0a228b15575b715822c6"
+ CACHE STRING ""
+ )
+
diff --git a/PKGBUILD b/PKGBUILD
index 976c0d8dc631..4f76c2191aeb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=retdec
pkgver=5.0
-pkgrel=1
+pkgrel=2
pkgdesc="A retargetable machine-code decompiler based on LLVM"
arch=('x86_64')
url="https://retdec.com/"
@@ -13,8 +13,18 @@ depends=('openssl' 'python' 'zlib')
makedepends=('cmake' 'doxygen' 'graphviz')
optdepends=('upx: To use UPX unpacker in the preprocessing stage'
'graphviz: To generate call or control flow grpahs')
-source=("https://github.com/avast/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('216dc62fd54ff06277497492dbf44bc7a91e39249d8aefdee2e4f10fc903ce85')
+source=("https://github.com/avast/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz"
+ '00-fix-missing-cstdint.patch'
+ '01-use-yaramod-v3.21.0.patch')
+sha256sums=('216dc62fd54ff06277497492dbf44bc7a91e39249d8aefdee2e4f10fc903ce85'
+ '4e4cd25fc540b45985d5b670c41de88edac3af2efd0b708a6c83b561b23631dc'
+ 'd461f420b23fe00669c24c82d94de97b8caffde84ad164ed47f19e77348c55e3')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -Np1 -i "$srcdir/00-fix-missing-cstdint.patch"
+ patch -Np1 -i "$srcdir/01-use-yaramod-v3.21.0.patch"
+}
build() {
cd "$srcdir/$pkgname-$pkgver"