summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD19
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68745b5b78c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = retdec-sh
+ pkgdesc = Shell scripts for decompiling and analyzing binary files through the retdec.com decompilation service by using their public REST API
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/s3rvac/retdec-sh
+ arch = any
+ license = MIT
+ depends = curl
+ source = https://github.com/s3rvac/retdec-sh/archive/0.1.tar.gz
+ sha512sums = ef6a633e698f8b63a29fd40a8815b418425f31ba78e76fe4c477cd781172845fab289e0805a06b0364ae1b2cb468c8388a02324da41ae8d9ceac4db1119fe6d9
+
+pkgname = retdec-sh
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6064234fcd2c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.tar.*
+*.zip
+*.7z
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..335799cd5c6e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Lubomir 'Kuci' Kucera <kuci24-at-gmail-dot-com>
+
+pkgname=retdec-sh
+pkgver=0.1
+pkgrel=1
+pkgdesc="Shell scripts for decompiling and analyzing binary files through the retdec.com decompilation service by using their public REST API"
+arch=('any')
+url="https://github.com/s3rvac/retdec-sh"
+license=('MIT')
+depends=('curl')
+source=("https://github.com/s3rvac/retdec-sh/archive/${pkgver}.tar.gz")
+sha512sums=('ef6a633e698f8b63a29fd40a8815b418425f31ba78e76fe4c477cd781172845fab289e0805a06b0364ae1b2cb468c8388a02324da41ae8d9ceac4db1119fe6d9')
+
+package() {
+ cd "${srcdir}/retdec-sh-${pkgver}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm755 "scripts/decompile.sh" "${pkgdir}/usr/bin/decompile"
+ install -Dm755 "scripts/fileinfo.sh" "${pkgdir}/usr/bin/fileinfo"
+}