summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 857f9003370e..c87a57b8e7fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = revng-bin
pkgdesc = An open source binary analysis framework based on LLVM and QEMU
- pkgver = 0.0.0.gc849342e
+ pkgver = 0.0.0.r1.g3b3cf7b9
pkgrel = 1
url = https://rev.ng/
arch = x86_64
license = GPL2
provides = revng
options = !strip
- source = https://rev.ng/downloads/revng-distributable/none_c849342e971fd3e491b123a855b9987e5f9ffcdf.tar.xz
+ source = https://rev.ng/downloads/revng-distributable/none_3b3cf7b97706fc264fa4b0aaf6425bfd104619ad.tar.xz
source = launcher.sh
- sha256sums = 631a351bebbedb0c655eec9c3514b609fcdcec88912f310d29d9929985eb476d
+ sha256sums = b891c84b791c9e48c0175e10ea49ad7b8d27dac614066d49af180d384019dbfe
sha256sums = 4605f93ff27ba081036acebb204af5e81614394357d941ae917e8e97e58d7252
pkgname = revng-bin
diff --git a/PKGBUILD b/PKGBUILD
index 7cc00f1d6302..4615d1e437d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: ⭐️NINIKA⭐️ <nikita6@bk.ru>
-_build_rev=c849342e971fd3e491b123a855b9987e5f9ffcdf
+_build_rev=3b3cf7b97706fc264fa4b0aaf6425bfd104619ad
+_build_num=1
pkgname=revng-bin
-pkgver=0.0.0.gc849342e
+pkgver=0.0.0.r1.g3b3cf7b9
pkgrel=1
pkgdesc="An open source binary analysis framework based on LLVM and QEMU"
arch=('x86_64')
@@ -14,12 +15,12 @@ source=(
"https://rev.ng/downloads/revng-distributable/none_${_build_rev}.tar.xz"
"launcher.sh"
)
-sha256sums=('631a351bebbedb0c655eec9c3514b609fcdcec88912f310d29d9929985eb476d'
+sha256sums=('b891c84b791c9e48c0175e10ea49ad7b8d27dac614066d49af180d384019dbfe'
'4605f93ff27ba081036acebb204af5e81614394357d941ae917e8e97e58d7252')
options=("!strip")
pkgver() {
- echo "0.0.0.g$(echo "$_build_rev" | cut -c -8)"
+ echo "0.0.0.r$_build_num.g$(echo "$_build_rev" | cut -c -8)"
}
package() {