summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--ChangeLog23
-rw-r--r--PKGBUILD11
-rw-r--r--fix_compilation.patch (renamed from iostream.patch)33
-rw-r--r--ri-li.changelog30
5 files changed, 71 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d92b2097ce26..5f63e4ce8851 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ri-li
pkgdesc = Drive a toy wood engine in many levels and collect all the coaches to win
pkgver = 2.0.1
- pkgrel = 4
+ pkgrel = 5
url = http://ri-li.sourceforge.net/
changelog = ri-li.changelog
arch = i686
@@ -11,10 +11,9 @@ pkgbase = ri-li
depends = sdl_mixer
source = http://downloads.sourceforge.net/sourceforge/ri-li/Ri-li-2.0.1.tar.bz2
source = ri-li.desktop
- source = iostream.patch
+ source = fix_compilation.patch
md5sums = 57a2ff50a0c704786da8adf61d78bf52
md5sums = ff57f8b04b212af3e6f8c600c3e0c35b
- md5sums = d953710f48bccf1f4de2f7d316c725fe
+ md5sums = 1736ab476f561a2f7ea809bcef54d0b7
pkgname = ri-li
-
diff --git a/ChangeLog b/ChangeLog
deleted file mode 100644
index 47e000c1db7b..000000000000
--- a/ChangeLog
+++ /dev/null
@@ -1,23 +0,0 @@
-2010-12-14 encelo <encelo@users.sourceforge.net>
-
- * PKGBUILD :
- Applying a new GCC compile patch
-
-2007-05-31 encelo <encelo@users.sourceforge.net>
-
- * PKGBUILD :
- Using $srcdir and $pkgdir variables
- Added x86_64 to the arch array
- Source downloading from downloads.sourceforge.net
- Applying a GCC 4.3 compile patch
-
- * ChangeLog :
- Compliant to ChangeLog.proto format
-
-2007-12-08 encelo <encelo@users.sourceforge.net>
-
- * PKGBUILD :
- Description shortened
- Dependencies updated
- License and arch field added
- .desktop file included
diff --git a/PKGBUILD b/PKGBUILD
index bafacaf13dbe..fcd04e1a10c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
# Contributor: Angelo Theodorou <encelo@users.sourceforge.net>
pkgname=ri-li
pkgver=2.0.1
-pkgrel=4
+pkgrel=5
pkgdesc="Drive a toy wood engine in many levels and collect all the coaches to win"
arch=('i686' 'x86_64')
url="http://ri-li.sourceforge.net/"
license=('GPL')
depends=('gcc-libs' 'sdl_mixer')
-changelog=('ri-li.changelog')
-source=(http://downloads.sourceforge.net/sourceforge/$pkgname/Ri-li-$pkgver.tar.bz2 ri-li.desktop iostream.patch)
-md5sums=('57a2ff50a0c704786da8adf61d78bf52' 'ff57f8b04b212af3e6f8c600c3e0c35b'
- 'd953710f48bccf1f4de2f7d316c725fe')
+changelog='ri-li.changelog'
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/Ri-li-$pkgver.tar.bz2 ri-li.desktop fix_compilation.patch)
+md5sums=('57a2ff50a0c704786da8adf61d78bf52' 'ff57f8b04b212af3e6f8c600c3e0c35b' '1736ab476f561a2f7ea809bcef54d0b7')
build() {
cd $srcdir/Ri-li-$pkgver
./configure --prefix=/usr
sed -i "s/SUBDIRS = src data Sounds gentoo/SUBDIRS = src data Sounds/" Makefile
- patch -p1 < $srcdir/iostream.patch
+ patch -p1 < $srcdir/fix_compilation.patch
make || return 1
}
diff --git a/iostream.patch b/fix_compilation.patch
index 5846bb32b359..a24952a65a14 100644
--- a/iostream.patch
+++ b/fix_compilation.patch
@@ -200,3 +200,36 @@ diff -urN Ri-li-2.0.1-orig/src//utils.cc Ri-li-2.0.1/src//utils.cc
/*** Variables globales ***/
/**************************/
extern sPreference Pref;
+diff -urN Ri-li-2.0.1-orig/src/sprite.cc Ri-li-2.0.1/src/sprite.cc
+--- Ri-li-2.0.1-orig/src/sprite.cc 2022-02-22 09:50:54.077854717 +0100
++++ Ri-li-2.0.1/src/sprite.cc 2022-02-22 09:55:05.251189551 +0100
+@@ -354,7 +354,7 @@
+ // Fabrique la surface
+ Image[i]=SDL_CreateRGBSurface((Dim[i].bpp-3)*SDL_SRCALPHA,Dim[i].L,Dim[i].H,Dim[i].bpp*8,
+ 0xff,0xff00,0xff0000,0xff000000*(Dim[i].bpp-3));
+- if(Image[i]<=NULL) {
++ if(Image[i]==NULL) {
+ cerr <<"Impossible de créer une Surface SDL!"<<endl;
+ return false;
+ }
+@@ -488,7 +488,7 @@
+ // Fabrique la surface
+ Image[0]=SDL_CreateRGBSurface((Dim[0].bpp-3)*SDL_SRCALPHA,Dim[0].L,Dim[0].H,Dim[0].bpp*8,
+ 0xff,0xff00,0xff0000,0xff000000*(Dim[0].bpp-3));
+- if(Image[0]<=NULL) {
++ if(Image[0]==NULL) {
+ cerr <<"Impossible de créer une Surface SDL!"<<endl;
+ return false;
+ }
+diff -urN Ri-li-2.0.1-orig/src/tableau.cc Ri-li-2.0.1/src/tableau.cc
+--- Ri-li-2.0.1-orig/src/tableau.cc 2022-02-22 09:50:54.077854717 +0100
++++ Ri-li-2.0.1/src/tableau.cc 2022-02-22 09:54:35.474522718 +0100
+@@ -87,7 +87,7 @@
+
+ // Alloue la mémoire
+ Buf=new unsigned char [sizeof(s_Tableau)*N+sizeof(int)+1];
+- if(Buf<=0) return false;
++ if(Buf==0) return false;
+
+ // Charge les tableaux
+ Buf[0]=N/256;
diff --git a/ri-li.changelog b/ri-li.changelog
index 375cac9a05c4..8d9b44acf181 100644
--- a/ri-li.changelog
+++ b/ri-li.changelog
@@ -1,4 +1,34 @@
+2022-02-22 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Modified and renamed the patch to fix compilation (many thanks to Michaël Lhomme)
+ Join the two changelog text files
+
2015-08-23 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
* PKGBUILD :
Added a package() function
+
+2010-12-14 encelo <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Applying a new GCC compile patch
+
+2007-05-31 encelo <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Using $srcdir and $pkgdir variables
+ Added x86_64 to the arch array
+ Source downloading from downloads.sourceforge.net
+ Applying a GCC 4.3 compile patch
+
+ * ChangeLog :
+ Compliant to ChangeLog.proto format
+
+2007-12-08 encelo <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Description shortened
+ Dependencies updated
+ License and arch field added
+ .desktop file included