summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3fa1beae50cb..a72f560d4e31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = rl_custom_function-git
pkgdesc = Enable to inject custom functions into any readline applications
- pkgver = r23.76bce87
+ pkgver = r25.931201a
pkgrel = 1
url = https://github.com/lincheney/rl_custom_function
install = rl_custom_function-git.install
arch = i686
arch = x86_64
license = GPL3
- makedepends = rust
makedepends = cargo
depends = readline
provides = rl_custom_function
diff --git a/PKGBUILD b/PKGBUILD
index 7d0f4eefbb15..edfab1e9fd77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgname=rl_custom_function-git
_pkgname=${pkgname%-git}
-pkgver=r23.76bce87
+pkgver=r25.931201a
pkgrel=1
pkgdesc="Enable to inject custom functions into any readline applications"
arch=('i686' 'x86_64')
url="https://github.com/lincheney/rl_custom_function"
license=('GPL3')
depends=('readline')
-makedepends=('rust' 'cargo')
+makedepends=('cargo')
provides=("$_pkgname")
install=$pkgname.install
source=("$_pkgname::git+https://github.com/lincheney/$_pkgname.git")
@@ -23,14 +23,17 @@ pkgver() {
build() {
cd "$srcdir/$_pkgname"
- cargo build --release
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --release --locked
touch main.c
gcc -m32 -shared main.c -o librl_custom_function.so
}
check() {
cd "$srcdir/$_pkgname"
- cargo test --release
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen
}
package() {