summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD9
2 files changed, 16 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26760211342a..9e32fe0f42b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,14 @@
pkgbase = rmlint-develop-git
- pkgver = 2.10.1.r210.g1ab4d8ae
+ pkgver = 2.10.1.r213.g183647b8
pkgrel = 1
url = https://github.com/sahib/rmlint
arch = x86_64
license = GPL3
+ checkdepends = dash
+ checkdepends = python-nose
+ checkdepends = python-parameterized
+ checkdepends = python-psutil
+ checkdepends = python-xattr
makedepends = binutils
makedepends = dconf
makedepends = desktop-file-utils
@@ -29,7 +34,7 @@ pkgname = rmlint-develop-git
depends = json-glib
depends = libelf
depends = util-linux-libs
- provides = rmlint=2.10.1.r210.g1ab4d8ae
+ provides = rmlint=2.10.1.r213.g183647b8
conflicts = rmlint
pkgname = rmlint-shredder-develop-git
@@ -41,6 +46,6 @@ pkgname = rmlint-shredder-develop-git
depends = python-gobject
depends = rmlint-develop-git
depends = xdg-utils
- provides = rmlint-shredder=2.10.1.r210.g1ab4d8ae
+ provides = rmlint-shredder=2.10.1.r213.g183647b8
conflicts = rmlint-shredder
diff --git a/PKGBUILD b/PKGBUILD
index 3fe2b94f4a23..b437a6d8b2ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname=rmlint
pkgbase=${_pkgname}-develop-git
pkgname=(rmlint-develop-git rmlint-shredder-develop-git)
-pkgver=2.10.1.r210.g1ab4d8ae
+pkgver=2.10.1.r213.g183647b8
pkgrel=1
url="https://github.com/sahib/rmlint"
license=('GPL3')
@@ -15,6 +15,8 @@ makedepends=('binutils' 'dconf' 'desktop-file-utils' 'gettext' 'git'
'gtksourceview3' 'json-glib' 'libelf' 'librsvg' 'python-cairo'
'python-gobject' 'python-requests' 'python-sphinx' 'scons'
'util-linux-libs' 'xdg-utils')
+checkdepends=('dash' 'python-nose' 'python-parameterized' 'python-psutil'
+ 'python-xattr')
source=("git+https://github.com/sahib/${_pkgname}.git#branch=develop")
md5sums=('SKIP')
@@ -29,6 +31,11 @@ build() {
scons -j4 DEBUG=1 --prefix="$pkgdir"/usr --actual-prefix=/usr
}
+check() {
+ cd "$_pkgname"
+ RM_TS_PRINT_CMD=1 python -m nose -d -a '!slow' -e 'test_symlinks' -e 'test_order'
+}
+
package_rmlint-develop-git() {
pkgdesc="Tool to remove duplicates and other lint, being much faster than fdupes"
depends=('binutils' 'json-glib' 'libelf' 'util-linux-libs')