summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--ChangeLog7
-rw-r--r--PKGBUILD25
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16edc19f912b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = rocheplot
+ pkgdesc = Plot the key stages in the evolution of a binary star
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = http://rocheplot.sourceforge.net/
+ changelog = ChangeLog
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = gcc-fortran
+ depends = pgplot
+ depends = libsufr
+ source = http://sourceforge.net/projects/rocheplot/files/rocheplot-0.1.0.tar.gz
+ sha512sums = 59b1c636d11d2860ab585e83719787cb476ce030d68aa4c6043555c9a63c4d0d8a04e7aaa48a8858aada2ef9067d4625025ac0c9891d97debf62f237d5ceb079
+
+pkgname = rocheplot
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..f9458f7e74ea
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,7 @@
+
+ChangeLog for rochePlot PKGBUILD
+http://rocheplot.sourceforge.net/
+
+* rochePlot-0.1.0-1 (2015-05-09 - AstroFloyd)
+ Initial PKGBUILD for rochePlot, to be uploaded to AUR
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa462d856610
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: AstroFloyd < AstroFloyd [at] gmail [dt] com >
+pkgname=rocheplot
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Plot the key stages in the evolution of a binary star"
+arch=('i686' 'x86_64')
+url="http://rocheplot.sourceforge.net/"
+license=('GPL3')
+depends=('pgplot' 'libsufr')
+makedepends=('cmake' 'gcc-fortran')
+changelog=ChangeLog
+source=("http://sourceforge.net/projects/$pkgname/files/$pkgname-$pkgver.tar.gz")
+sha512sums=('59b1c636d11d2860ab585e83719787cb476ce030d68aa4c6043555c9a63c4d0d8a04e7aaa48a8858aada2ef9067d4625025ac0c9891d97debf62f237d5ceb079')
+
+build() {
+ mkdir -p "$pkgname-$pkgver"/build
+ cd "$pkgname-$pkgver"/build/
+ cmake -DCMAKE_INSTALL_PREFIX:PATH="$pkgdir/usr/" ..
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"/build/
+ make install
+}