summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD61
-rw-r--r--rocketsrocketsrockets-hib.x86.in4
-rw-r--r--rocketsrocketsrockets-hib.x86_64.in4
4 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8bc5378eab33
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = rocketsrocketsrockets-hib
+ pkgdesc = ROCKETS fire ROCKETS at ROCKETS in this action-arcade, arena-combat, gorgeous festival-of-fireworks!
+ pkgver = 20150915
+ pkgrel = 1
+ url = https://rocketsrocketsrockets.com/
+ arch = x86_64
+ license = custom:commercial
+ source_x86_64 = hib://Rockets.x86_64.zip
+ source_x86_64 = rocketsrocketsrockets-hib.x86_64.in
+ md5sums_x86_64 = af4c6b8e2b6d9fabc2b143c948010ffd
+ md5sums_x86_64 = 2bfd3eef1dc360418824b71246e2bc4e
+
+pkgname = rocketsrocketsrockets-hib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca9ea4327d4c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Moviuro <moviuro+aur at gmail dot com>
+
+pkgname=rocketsrocketsrockets-hib
+pkgver=20150915
+pkgrel=1
+pkgdesc="ROCKETS fire ROCKETS at ROCKETS in this action-arcade, arena-combat, gorgeous festival-of-fireworks!"
+# i686 files are also available, and there are some comments to help if needed
+arch=("x86_64")
+url="https://rocketsrocketsrockets.com/"
+license=("custom:commercial")
+depends_x86_64=()
+depends_i686=()
+source_x86_64=("hib://Rockets.x86_64.zip"
+ "$pkgname.x86_64.in")
+source_i686=("hib://Rockets.x86.zip"
+ "$pkgname.x86.in")
+md5sums_x86_64=("af4c6b8e2b6d9fabc2b143c948010ffd"
+ "2bfd3eef1dc360418824b71246e2bc4e")
+md5sums_i686=("51745586ddc727c6b592a31fcc2cbb43"
+ "ec366ffdfbb4396f3f68b9069c89464c")
+
+# Disable compression of the package
+PKGEXT='.pkg.tar'
+
+package() {
+ # Binaries
+ install -Dm755 "$srcdir/Rockets.x86_64" "$pkgdir/opt/$pkgname/Rockets.x86_64"
+ #install -Dm755 "$srcdir/Rockets.x86" "$pkgdir/opt/$pkgname/Rockets.x86"
+
+ # Data
+ # Hardlink files to save the disk space
+ cp -Ral "$srcdir/Rockets_Data" "$pkgdir/opt/$pkgname/Rockets_Data"
+ # Remove x86 files on x86_64
+ find "$pkgdir/opt/$pkgname/Rockets_Data" -type d -name x86 -print0 | xargs -0 rm -r
+ # Remove x86_64 files on i686
+ #find "$pkgdir/opt/$pkgname/Rockets_Data" -type d -name x86_64 -exec rm -r {} \;
+
+ # Fix permissions
+ find "$pkgdir/opt/$pkgname/Rockets_Data" -type d -print0 | xargs -0 chmod 755
+ find "$pkgdir/opt/$pkgname/Rockets_Data" -type f -print0 | xargs -0 chmod 644
+
+ # Icon
+ ln -s "/opt/$pkgname/Rockets_Data/Resources/UnityPlayer.png" "$pkgdir/opt/$pkgname/icon.png"
+
+ #
+ # System integration
+ #
+
+ # /bin
+ install -m755 -d "$pkgdir/usr/bin/"
+ sed "s!@PKGDEST@!/opt/$pkgname/!" "$pkgname.x86_64.in" > "$pkgdir/usr/bin/$pkgname"
+ #sed "s!@PKGDEST@!/opt/$pkgname/!" "$pkgname.x86.in" > "$pkgdir/usr/bin/$pkgname"
+ chmod 755 "$pkgdir/usr/bin/$pkgname"
+
+ # License
+ # None to be found in the archive
+
+ # Icon
+ install -m755 -d "$pkgdir/usr/share/pixmaps/"
+ ln -s "/opt/$pkgname/icon.png" "$pkgdir/usr/share/pixmaps/${pkgname}.png"
+}
diff --git a/rocketsrocketsrockets-hib.x86.in b/rocketsrocketsrockets-hib.x86.in
new file mode 100644
index 000000000000..377249ae924b
--- /dev/null
+++ b/rocketsrocketsrockets-hib.x86.in
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd @PKGDEST@
+./Rockets.x86 "$@"
diff --git a/rocketsrocketsrockets-hib.x86_64.in b/rocketsrocketsrockets-hib.x86_64.in
new file mode 100644
index 000000000000..19f2bf6f656d
--- /dev/null
+++ b/rocketsrocketsrockets-hib.x86_64.in
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd @PKGDEST@
+./Rockets.x86_64 "$@"