summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
-rw-r--r--fix-compiler-with-gcc-8.1.1.patch13
3 files changed, 6 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d3050178ab3..cdd1ab17aa39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rocksdb-lite
pkgdesc = Embedded key-value store for fast storage (lite version)
- pkgver = 5.14.3
+ pkgver = 5.15.10
pkgrel = 1
url = http://rocksdb.org
arch = i686
@@ -14,9 +14,8 @@ pkgbase = rocksdb-lite
depends = snappy
depends = gcc-libs
conflicts = rocksdb
- source = https://github.com/facebook/rocksdb/archive/v5.14.3.zip
- source = fix-compiler-with-gcc-8.1.1.patch
- sha256sums = e927efa48b01100bfe7aa43cd0f18c1a3c37afdcdf7337d89cd9ab7541d4f07a
+ source = https://github.com/facebook/rocksdb/archive/v5.15.10.zip
+ sha256sums = 16356771775376b50e5cd4e7a185e84f398493183d375ff14cd6d396cdae6ea0
sha256sums = 079e9b29bc7174d6a6a6dd50602f9d2a561ea55d42328c75576acd666fe92dd5
pkgname = rocksdb-lite
diff --git a/PKGBUILD b/PKGBUILD
index 06b241ca4393..096bf3eb574e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=rocksdb-lite
-pkgver=5.14.3
+pkgver=5.15.10
pkgrel=1
pkgdesc='Embedded key-value store for fast storage (lite version)'
arch=(i686 x86_64)
@@ -10,9 +10,8 @@ license=('Apache')
depends=(gperftools zlib bzip2 lz4 snappy gcc-libs)
conflicts=(rocksdb)
checkdepends=(python2)
-source=(https://github.com/facebook/rocksdb/archive/v$pkgver.zip
- fix-compiler-with-gcc-8.1.1.patch)
-sha256sums=('e927efa48b01100bfe7aa43cd0f18c1a3c37afdcdf7337d89cd9ab7541d4f07a'
+source=(https://github.com/facebook/rocksdb/archive/v$pkgver.zip)
+sha256sums=('16356771775376b50e5cd4e7a185e84f398493183d375ff14cd6d396cdae6ea0'
'079e9b29bc7174d6a6a6dd50602f9d2a561ea55d42328c75576acd666fe92dd5')
prepare() {
@@ -21,7 +20,6 @@ prepare() {
if [ "$CARCH" == "armv6h" ]; then
sed -e 's/-momit-leaf-frame-pointer//' -i Makefile
fi
- patch -Np1 -i ../fix-compiler-with-gcc-8.1.1.patch
}
build() {
diff --git a/fix-compiler-with-gcc-8.1.1.patch b/fix-compiler-with-gcc-8.1.1.patch
deleted file mode 100644
index ef70a4af6719..000000000000
--- a/fix-compiler-with-gcc-8.1.1.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/util/status.cc b/util/status.cc
-index 319b0d9a4e..fadfa7d65d 100644
---- a/util/status.cc
-+++ b/util/status.cc
-@@ -25,7 +25,7 @@ const char* Status::CopyState(const char* state) {
- ret = strncpy_s(result, cch, state, cch - 1);
- assert(ret == 0);
- #else
-- std::strncpy(result, state, cch - 1);
-+ std::strncpy(result, state, cch);
- #endif
- return result;
- }