summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a707e2592d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = rofi-adi1090x
+ pkgdesc = A huge collection of Rofi based custom Applets, Launchers & Powermenus.
+ pkgver = r74.60685ab
+ pkgrel = 1
+ url = https://github.com/adi1090x/rofi
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = rofi
+ provides = rofi-adi1090x
+ conflicts = rofi-adi1090x
+ backup = usr/share/sddm/themes/tokyo-night-sddm/theme.conf
+ source = git+https://github.com/adi1090x/rofi.git
+ sha256sums = SKIP
+
+pkgname = rofi-adi1090x
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4367ae4a50ac
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d007745df02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Julian Poidevin <poidevin dot julian at gmail dot com>
+pkgname=rofi-adi1090x
+pkgver=r74.60685ab
+pkgrel=1
+epoch=
+pkgdesc="A huge collection of Rofi based custom Applets, Launchers & Powermenus."
+arch=('any')
+url="https://github.com/adi1090x/rofi"
+license=(GPL3)
+groups=()
+depends=('rofi')
+makedepends=(git)
+optdepends=()
+provides=('rofi-adi1090x')
+conflicts=('rofi-adi1090x')
+backup=('usr/share/sddm/themes/tokyo-night-sddm/theme.conf')
+source=('git+https://github.com/adi1090x/rofi.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/rofi"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/rofi"
+ chmod +x setup.sh
+}
+
+package() {
+ cd "${srcdir}/rofi"
+ ./setup.sh
+}