summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
2 files changed, 19 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78368220985e..095a3ab5c09e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
+# Generated by mksrcinfo v8
+# Thu Mar 24 02:20:23 UTC 2016
pkgbase = ros-indigo-dynamic-reconfigure
pkgdesc = ROS - This unary stack contains the dynamic_reconfigure package which provides a means to change node parameters at any time without having to restart the node.
- pkgver = 1.5.38
- pkgrel = 3
+ pkgver = 1.5.43
+ pkgrel = 1
url = http://ros.org/wiki/dynamic_reconfigure
arch = any
license = BSD
makedepends = cmake
- makedepends = git
makedepends = ros-build-tools
makedepends = ros-indigo-roscpp-serialization
makedepends = ros-indigo-roscpp
@@ -22,8 +23,8 @@ pkgbase = ros-indigo-dynamic-reconfigure
depends = ros-indigo-rospy
depends = ros-indigo-roslib
depends = boost
- source = dynamic_reconfigure::git+https://github.com/ros-gbp/dynamic_reconfigure-release.git#tag=release/indigo/dynamic_reconfigure/1.5.38-0
- md5sums = SKIP
+ source = ros-indigo-dynamic-reconfigure-1.5.43-0.tar.gz::https://github.com/ros-gbp/dynamic_reconfigure-release/archive/release/indigo/dynamic_reconfigure/1.5.43-0.tar.gz
+ sha256sums = 2941e38dc52f2b5378f1418213a85d413adb0cd5cddf3d253f23fc6c235d89d1
pkgname = ros-indigo-dynamic-reconfigure
diff --git a/PKGBUILD b/PKGBUILD
index 80f1cf5f3212..3c97ce01b5b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,10 @@ pkgdesc="ROS - This unary stack contains the dynamic_reconfigure package which p
url='http://ros.org/wiki/dynamic_reconfigure'
pkgname='ros-indigo-dynamic-reconfigure'
-pkgver='1.5.38'
+pkgver='1.5.43'
_pkgver_patch=0
arch=('any')
-pkgrel=3
+pkgrel=1
license=('BSD')
ros_makedepends=(ros-indigo-roscpp-serialization
@@ -16,7 +16,7 @@ ros_makedepends=(ros-indigo-roscpp-serialization
ros-indigo-rostest
ros-indigo-catkin
ros-indigo-message-generation)
-makedepends=('cmake' 'git' 'ros-build-tools'
+makedepends=('cmake' 'ros-build-tools'
${ros_makedepends[@]}
boost)
@@ -29,10 +29,16 @@ ros_depends=(ros-indigo-rosservice
depends=(${ros_depends[@]}
boost)
-_tag=release/indigo/dynamic_reconfigure/${pkgver}-${_pkgver_patch}
-_dir=dynamic_reconfigure
-source=("${_dir}"::"git+https://github.com/ros-gbp/dynamic_reconfigure-release.git"#tag=${_tag})
-md5sums=('SKIP')
+# Git version (e.g. for debugging)
+# _tag=release/indigo/dynamic_reconfigure/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/dynamic_reconfigure-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="dynamic_reconfigure-release-release-indigo-dynamic_reconfigure-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/dynamic_reconfigure-release/archive/release/indigo/dynamic_reconfigure/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('2941e38dc52f2b5378f1418213a85d413adb0cd5cddf3d253f23fc6c235d89d1')
build() {
# Use ROS environment variables