summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
2 files changed, 17 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b74693a0359..88854e9d4d1d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
+# Generated by mksrcinfo v8
+# Thu Mar 24 02:40:21 UTC 2016
pkgbase = ros-indigo-ros-tutorials
pkgdesc = ROS - ros_tutorials contains packages that demonstrate various features of ROS, as well as support packages which help demonstrate those features.
- pkgver = 0.5.4
+ pkgver = 0.5.5
pkgrel = 1
url = http://www.ros.org/wiki/ros_tutorials
arch = any
license = BSD
makedepends = cmake
- makedepends = git
makedepends = ros-build-tools
makedepends = ros-indigo-catkin
depends = ros-indigo-rospy-tutorials
depends = ros-indigo-roscpp-tutorials
depends = ros-indigo-turtlesim
- source = ros_tutorials::git+https://github.com/ros-gbp/ros_tutorials-release.git#tag=release/indigo/ros_tutorials/0.5.4-0
- md5sums = SKIP
+ source = ros-indigo-ros-tutorials-0.5.5-0.tar.gz::https://github.com/ros-gbp/ros_tutorials-release/archive/release/indigo/ros_tutorials/0.5.5-0.tar.gz
+ sha256sums = 0d1355749aecd00bdc48c092edfa99669d7caf777bec19c8a0232004f90ad614
pkgname = ros-indigo-ros-tutorials
diff --git a/PKGBUILD b/PKGBUILD
index fe34d30a8d65..824ea88163f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@ pkgdesc="ROS - ros_tutorials contains packages that demonstrate various features
url='http://www.ros.org/wiki/ros_tutorials'
pkgname='ros-indigo-ros-tutorials'
-pkgver='0.5.4'
+pkgver='0.5.5'
_pkgver_patch=0
arch=('any')
pkgrel=1
license=('BSD')
ros_makedepends=(ros-indigo-catkin)
-makedepends=('cmake' 'git' 'ros-build-tools'
+makedepends=('cmake' 'ros-build-tools'
${ros_makedepends[@]})
ros_depends=(ros-indigo-rospy-tutorials
@@ -19,10 +19,16 @@ ros_depends=(ros-indigo-rospy-tutorials
ros-indigo-turtlesim)
depends=(${ros_depends[@]})
-_tag=release/indigo/ros_tutorials/${pkgver}-${_pkgver_patch}
-_dir=ros_tutorials
-source=("${_dir}"::"git+https://github.com/ros-gbp/ros_tutorials-release.git"#tag=${_tag})
-md5sums=('SKIP')
+# Git version (e.g. for debugging)
+# _tag=release/indigo/ros_tutorials/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ros_tutorials-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ros_tutorials-release-release-indigo-ros_tutorials-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_tutorials-release/archive/release/indigo/ros_tutorials/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('0d1355749aecd00bdc48c092edfa99669d7caf777bec19c8a0232004f90ad614')
build() {
# Use ROS environment variables