summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD22
2 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9ea583244b0..09120e788682 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
+# Generated by mksrcinfo v8
+# Thu Mar 24 02:24:31 UTC 2016
pkgbase = ros-indigo-rqt-plot
pkgdesc = ROS - rqt_plot provides a GUI plugin visualizing numeric values in a 2D plot using different plotting backends.
- pkgver = 0.3.12
+ pkgver = 0.3.13
pkgrel = 1
url = http://ros.org/wiki/rqt_plot
arch = any
license = BSD
makedepends = cmake
- makedepends = git
makedepends = ros-build-tools
makedepends = ros-indigo-catkin
depends = ros-indigo-rqt-gui
@@ -16,10 +17,10 @@ pkgbase = ros-indigo-rqt-plot
depends = ros-indigo-rostopic
depends = ros-indigo-qt-gui-py-common
depends = python2-rospkg
- depends = pyqwt
depends = python2-matplotlib
- source = rqt_plot::git+https://github.com/ros-gbp/rqt_common_plugins-release.git#tag=release/indigo/rqt_plot/0.3.12-0
- md5sums = SKIP
+ depends = python2-pyqwt
+ source = ros-indigo-rqt-plot-0.3.13-0.tar.gz::https://github.com/ros-gbp/rqt_common_plugins-release/archive/release/indigo/rqt_plot/0.3.13-0.tar.gz
+ sha256sums = af80549b2bc71ed09fbef212375adb9623c4eadc25c45b67afe17ca52b4dfebc
pkgname = ros-indigo-rqt-plot
diff --git a/PKGBUILD b/PKGBUILD
index 7ddb20c3870d..4dfd45b8535b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@ pkgdesc="ROS - rqt_plot provides a GUI plugin visualizing numeric values in a 2D
url='http://ros.org/wiki/rqt_plot'
pkgname='ros-indigo-rqt-plot'
-pkgver='0.3.12'
+pkgver='0.3.13'
_pkgver_patch=0
arch=('any')
pkgrel=1
license=('BSD')
ros_makedepends=(ros-indigo-catkin)
-makedepends=('cmake' 'git' 'ros-build-tools'
+makedepends=('cmake' 'ros-build-tools'
${ros_makedepends[@]})
ros_depends=(ros-indigo-rqt-gui
@@ -22,13 +22,19 @@ ros_depends=(ros-indigo-rqt-gui
ros-indigo-qt-gui-py-common)
depends=(${ros_depends[@]}
python2-rospkg
- pyqwt
- python2-matplotlib)
+ python2-matplotlib
+ python2-pyqwt)
-_tag=release/indigo/rqt_plot/${pkgver}-${_pkgver_patch}
-_dir=rqt_plot
-source=("${_dir}"::"git+https://github.com/ros-gbp/rqt_common_plugins-release.git"#tag=${_tag})
-md5sums=('SKIP')
+# Git version (e.g. for debugging)
+# _tag=release/indigo/rqt_plot/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/rqt_common_plugins-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="rqt_common_plugins-release-release-indigo-rqt_plot-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/rqt_common_plugins-release/archive/release/indigo/rqt_plot/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('af80549b2bc71ed09fbef212375adb9623c4eadc25c45b67afe17ca52b4dfebc')
build() {
# Use ROS environment variables