summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
2 files changed, 17 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21431d2ebdc0..757c0d6c34b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
+# Generated by mksrcinfo v8
+# Sun May 22 21:57:03 UTC 2016
pkgbase = ros-jade-rqt-py-console
pkgdesc = ROS - rqt_py_console is a Python GUI plugin providing an interactive Python console.
- pkgver = 0.3.12
+ pkgver = 0.3.13
pkgrel = 1
url = http://ros.org/wiki/rqt_py_console
arch = any
license = BSD
makedepends = cmake
- makedepends = git
makedepends = ros-build-tools
makedepends = ros-jade-catkin
depends = ros-jade-qt-gui-py-common
@@ -15,8 +16,8 @@ pkgbase = ros-jade-rqt-py-console
depends = ros-jade-qt-gui
depends = ros-jade-rospy
depends = python2-rospkg
- source = rqt_py_console::git+https://github.com/ros-gbp/rqt_common_plugins-release.git#tag=release/jade/rqt_py_console/0.3.12-0
- md5sums = SKIP
+ source = ros-jade-rqt-py-console-0.3.13-0.tar.gz::https://github.com/ros-gbp/rqt_common_plugins-release/archive/release/jade/rqt_py_console/0.3.13-0.tar.gz
+ sha256sums = 0b7ba0e99a93f4a419bb4623837f1673ebe8dd987ef6bb0fb2c38a1c6abc5f9a
pkgname = ros-jade-rqt-py-console
diff --git a/PKGBUILD b/PKGBUILD
index e8550f87a3a9..457a57caf347 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@ pkgdesc="ROS - rqt_py_console is a Python GUI plugin providing an interactive Py
url='http://ros.org/wiki/rqt_py_console'
pkgname='ros-jade-rqt-py-console'
-pkgver='0.3.12'
+pkgver='0.3.13'
_pkgver_patch=0
arch=('any')
pkgrel=1
license=('BSD')
ros_makedepends=(ros-jade-catkin)
-makedepends=('cmake' 'git' 'ros-build-tools'
+makedepends=('cmake' 'ros-build-tools'
${ros_makedepends[@]})
ros_depends=(ros-jade-qt-gui-py-common
@@ -22,10 +22,16 @@ ros_depends=(ros-jade-qt-gui-py-common
depends=(${ros_depends[@]}
python2-rospkg)
-_tag=release/jade/rqt_py_console/${pkgver}-${_pkgver_patch}
-_dir=rqt_py_console
-source=("${_dir}"::"git+https://github.com/ros-gbp/rqt_common_plugins-release.git"#tag=${_tag})
-md5sums=('SKIP')
+# Git version (e.g. for debugging)
+# _tag=release/jade/rqt_py_console/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/rqt_common_plugins-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="rqt_common_plugins-release-release-jade-rqt_py_console-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/rqt_common_plugins-release/archive/release/jade/rqt_py_console/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('0b7ba0e99a93f4a419bb4623837f1673ebe8dd987ef6bb0fb2c38a1c6abc5f9a')
build() {
# Use ROS environment variables