summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD63
2 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0c2a3cc87bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Tue Dec 27 08:18:18 UTC 2016
+pkgbase = ros-kinetic-rosserial-client
+ pkgdesc = ROS - Generalized client side source for rosserial.
+ pkgver = 0.7.5
+ pkgrel = 1
+ url = http://ros.org/wiki/rosserial_client
+ arch = any
+ license = BSD
+ makedepends = cmake
+ makedepends = ros-build-tools
+ makedepends = ros-kinetic-catkin
+ depends = ros-kinetic-std-msgs
+ depends = ros-kinetic-rosserial-msgs
+ depends = ros-kinetic-tf
+ depends = ros-kinetic-rosbash
+ depends = ros-kinetic-rospy
+ source = ros-kinetic-rosserial-client-0.7.5-0.tar.gz::https://github.com/ros-gbp/rosserial-release/archive/release/kinetic/rosserial_client/0.7.5-0.tar.gz
+ sha256sums = efeadc5d5ea490e8fff78e0afcc9f31438daa69138b96216f33f9c5253f6483b
+
+pkgname = ros-kinetic-rosserial-client
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8227bd9d2c28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Generalized client side source for rosserial."
+url='http://ros.org/wiki/rosserial_client'
+
+pkgname='ros-kinetic-rosserial-client'
+pkgver='0.7.5'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-kinetic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-kinetic-std-msgs
+ ros-kinetic-rosserial-msgs
+ ros-kinetic-tf
+ ros-kinetic-rosbash
+ ros-kinetic-rospy)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/kinetic/rosserial_client/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/rosserial-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="rosserial-release-release-kinetic-rosserial_client-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/rosserial-release/archive/release/kinetic/rosserial_client/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('efeadc5d5ea490e8fff78e0afcc9f31438daa69138b96216f33f9c5253f6483b')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/kinetic/setup.bash ] && source /opt/ros/kinetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}