summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 20 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a34630dc3752..2359d635e1cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,22 @@
# Generated by mksrcinfo v8
-# Sun Nov 12 16:15:27 UTC 2017
+# Thu Feb 15 21:02:52 UTC 2018
pkgbase = ros-lunar-catkin
pkgdesc = ROS - Low-level build system macros and infrastructure for ROS.
- pkgver = 0.7.8
+ pkgver = 0.7.11
pkgrel = 1
url = http://www.ros.org/wiki/catkin
arch = any
license = BSD
- checkdepends = python2-nose
- checkdepends = python2-mock
- makedepends = cmake
makedepends = ros-build-tools
- depends = gtest
+ depends = cmake
+ depends = gmock
depends = python2-nose
- depends = python2-catkin_pkg
depends = python2-empy
+ depends = gtest
+ depends = python2-catkin_pkg
depends = python2
- source = ros-lunar-catkin-0.7.8-0.tar.gz::https://github.com/ros-gbp/catkin-release/archive/release/lunar/catkin/0.7.8-0.tar.gz
- sha256sums = 2057edf73b042a304447c7433e97056f07a32e74a98a01b40ecd06064f1603b9
+ source = ros-lunar-catkin-0.7.11-0.tar.gz::https://github.com/ros-gbp/catkin-release/archive/release/lunar/catkin/0.7.11-0.tar.gz
+ sha256sums = aaf9a8408117594b344d82576414165320fb485c21979dee9441c885bd5e6c13
pkgname = ros-lunar-catkin
diff --git a/PKGBUILD b/PKGBUILD
index a983c5e0ae16..3bef7a4976a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,29 +4,26 @@ pkgdesc="ROS - Low-level build system macros and infrastructure for ROS."
url='http://www.ros.org/wiki/catkin'
pkgname='ros-lunar-catkin'
-pkgver='0.7.8'
+pkgver='0.7.11'
_pkgver_patch=0
arch=('any')
pkgrel=1
license=('BSD')
ros_makedepends=()
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]})
+makedepends=(${ros_makedepends[@]}
+ ros-build-tools)
ros_depends=()
depends=(${ros_depends[@]}
- gtest
+ cmake
+ gmock
python2-nose
- python2-catkin_pkg
python2-empy
+ gtest
+ python2-catkin_pkg
python2)
-ros_checkdepends=()
-checkdepends=(${ros_checkdepends[@]}
- python2-nose
- python2-mock)
-
# Git version (e.g. for debugging)
# _tag=release/lunar/catkin/${pkgver}-${_pkgver_patch}
# _dir=${pkgname}
@@ -35,8 +32,10 @@ checkdepends=(${ros_checkdepends[@]}
# Tarball version (faster download)
_dir="catkin-release-release-lunar-catkin-${pkgver}-${_pkgver_patch}"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/catkin-release/archive/release/lunar/catkin/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('2057edf73b042a304447c7433e97056f07a32e74a98a01b40ecd06064f1603b9')
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/catkin-release/archive/release/lunar/catkin/${pkgver}-${_pkgver_patch}.tar.gz" )
+sha256sums=('aaf9a8408117594b344d82576414165320fb485c21979dee9441c885bd5e6c13' )
+
+
build() {
# Use ROS environment variables
@@ -55,6 +54,7 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=OFF \
-DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DCMAKE_PREFIX_PATH=/opt/ros/lunar \
-DPYTHON_EXECUTABLE=/usr/bin/python2 \
-DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
-DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \