summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 18 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83e9657ce682..458a82f63b51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = ros-melodic-ecl-errors
+pkgbase = ros-noetic-ecl-errors
pkgdesc = ROS - This library provides lean and mean error mechanisms.
pkgver = 0.61.6
pkgrel = 2
@@ -7,13 +7,13 @@ pkgbase = ros-melodic-ecl-errors
license = BSD
makedepends = cmake
makedepends = ros-build-tools
- makedepends = ros-melodic-ecl-license
- makedepends = ros-melodic-ecl-config
- makedepends = ros-melodic-catkin
- depends = ros-melodic-ecl-license
- depends = ros-melodic-ecl-config
- source = ros-melodic-ecl-errors-0.61.6.tar.gz::https://github.com/stonier/ecl_lite/archive/0.61.6.tar.gz
+ makedepends = ros-noetic-ecl-license
+ makedepends = ros-noetic-ecl-config
+ makedepends = ros-noetic-catkin
+ depends = ros-noetic-ecl-license
+ depends = ros-noetic-ecl-config
+ source = ros-noetic-ecl-errors-0.61.6.tar.gz::https://github.com/stonier/ecl_lite/archive/0.61.6.tar.gz
sha256sums = b8a02aabecc9a47bde44c83c7e02669e7ce9a3e43f51315b89d10960ed83f3cc
-pkgname = ros-melodic-ecl-errors
+pkgname = ros-noetic-ecl-errors
diff --git a/PKGBUILD b/PKGBUILD
index e6f86bebe662..b25cdc4bf814 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,24 @@
pkgdesc="ROS - This library provides lean and mean error mechanisms."
url='https://wiki.ros.org/ecl_errors'
-pkgname='ros-melodic-ecl-errors'
+pkgname='ros-noetic-ecl-errors'
pkgver='0.61.6'
arch=('any')
pkgrel=2
license=('BSD')
-ros_makedepends=(ros-melodic-ecl-license
- ros-melodic-ecl-config
- ros-melodic-catkin)
+ros_makedepends=(ros-noetic-ecl-license
+ ros-noetic-ecl-config
+ ros-noetic-catkin)
makedepends=('cmake' 'ros-build-tools'
${ros_makedepends[@]})
-ros_depends=(ros-melodic-ecl-license
- ros-melodic-ecl-config)
+ros_depends=(ros-noetic-ecl-license
+ ros-noetic-ecl-config)
depends=(${ros_depends[@]})
# Git version (e.g. for debugging)
-# _tag=release/melodic/ecl_errors/${pkgver}-${_pkgver_patch}
+# _tag=release/noetic/ecl_errors/${pkgver}-${_pkgver_patch}
# _dir=${pkgname}
# source=("${_dir}"::"git+https://github.com/yujinrobot-release/ecl_lite-release.git"#tag=${_tag})
# sha256sums=('SKIP')
@@ -32,24 +32,17 @@ sha256sums=('b8a02aabecc9a47bde44c83c7e02669e7ce9a3e43f51315b89d10960ed83f3cc')
build() {
# Use ROS environment variables
source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
# Create build directory
[ -d ${srcdir}/build ] || mkdir ${srcdir}/build
cd ${srcdir}/build
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
# Build project
cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=-python3.7m \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}