summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD60
2 files changed, 33 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f6f34a06d86..8860c48661b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-noetic-pluginlib-tutorials
pkgdesc = ROS - The pluginlib_tutorials package.
- pkgver = 0.1.11
- pkgrel = 4
+ pkgver = 0.2.0
+ pkgrel = 1
url = https://wiki.ros.org/pluginlib/Tutorials
arch = i686
arch = x86_64
@@ -16,8 +16,8 @@ pkgbase = ros-noetic-pluginlib-tutorials
makedepends = ros-noetic-catkin
depends = ros-noetic-pluginlib
depends = ros-noetic-roscpp
- source = ros-noetic-pluginlib-tutorials-0.1.11.tar.gz::https://github.com/ros/common_tutorials/archive/0.1.11.tar.gz
- sha256sums = e6015c289219df58253809254baa53dbf2f3190b61d77fac2b2fb8b8c12f3ec1
+ source = ros-noetic-pluginlib-tutorials-0.2.0.tar.gz::https://github.com/ros/common_tutorials/archive/0.2.0.tar.gz
+ sha256sums = 61b4f75a846264debe4f8eb4c7090f21079c5cd368f85124cf13eca6340570f3
pkgname = ros-noetic-pluginlib-tutorials
diff --git a/PKGBUILD b/PKGBUILD
index 922d92cde1ab..3100f8116905 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,58 +1,56 @@
-# Script generated with import_catkin_packages.py.
-# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - The pluginlib_tutorials package."
url='https://wiki.ros.org/pluginlib/Tutorials'
pkgname='ros-noetic-pluginlib-tutorials'
-pkgver='0.1.11'
+pkgver='0.2.0'
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
-pkgrel=4
+pkgrel=1
license=('BSD')
ros_makedepends=(
- ros-noetic-pluginlib
- ros-noetic-roscpp
- ros-noetic-catkin
+ ros-noetic-pluginlib
+ ros-noetic-roscpp
+ ros-noetic-catkin
)
makedepends=(
- 'cmake'
- 'ros-build-tools'
- ${ros_makedepends[@]}
+ cmake
+ ros-build-tools
+ ${ros_makedepends[@]}
)
ros_depends=(
- ros-noetic-pluginlib
- ros-noetic-roscpp
+ ros-noetic-pluginlib
+ ros-noetic-roscpp
)
depends=(
- ${ros_depends[@]}
+ ${ros_depends[@]}
)
_dir="common_tutorials-${pkgver}/pluginlib_tutorials"
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros/common_tutorials/archive/${pkgver}.tar.gz")
-sha256sums=('e6015c289219df58253809254baa53dbf2f3190b61d77fac2b2fb8b8c12f3ec1')
+sha256sums=('61b4f75a846264debe4f8eb4c7090f21079c5cd368f85124cf13eca6340570f3')
build() {
- # Use ROS environment variables.
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
-
- # Create the build directory.
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
-
- # Build the project.
- cmake ${srcdir}/${_dir} \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
- -DPYTHON_EXECUTABLE=/usr/bin/python \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
+
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}