summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 6 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a739407e945..2b7c1a044f43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-noetic-python-qt-binding
pkgdesc = ROS - This stack provides Python bindings for Qt.
pkgver = 0.4.4
- pkgrel = 4
+ pkgrel = 5
url = https://wiki.ros.org/python_qt_binding
arch = any
license = BSD
@@ -10,10 +10,8 @@ pkgbase = ros-noetic-python-qt-binding
makedepends = ros-noetic-catkin
makedepends = ros-noetic-rosbuild
makedepends = qt5-base
- depends = python-pyqt5
+ depends = python-pyqt5-sip4
source = ros-noetic-python-qt-binding-0.4.4.tar.gz::https://github.com/ros-visualization/python_qt_binding/archive/0.4.4.tar.gz
- source = sip.patch::https://github.com/ros-visualization/python_qt_binding/commit/7095b4de210e2b235606f73565908f9af413db96.patch
sha256sums = bcb5076226100f901e6a22656cf69ef0e8d5f1845670e6fad6fc5fdcb3a1dd07
- sha256sums = cd9774272b38183a30275613fd593f0b2de9e18192d2f5c98b26cd4e5cf33d53
pkgname = ros-noetic-python-qt-binding
diff --git a/PKGBUILD b/PKGBUILD
index 31087443883d..077ed4686c97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ url='https://wiki.ros.org/python_qt_binding'
pkgname='ros-noetic-python-qt-binding'
pkgver='0.4.4'
arch=('any')
-pkgrel=4
+pkgrel=5
license=('BSD')
ros_makedepends=(
@@ -24,19 +24,12 @@ ros_depends=(
depends=(
${ros_depends[@]}
- python-pyqt5
+ python-pyqt5-sip4
)
_dir="python_qt_binding-${pkgver}"
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-visualization/python_qt_binding/archive/${pkgver}.tar.gz"
- "sip.patch"::"https://github.com/ros-visualization/python_qt_binding/commit/7095b4de210e2b235606f73565908f9af413db96.patch")
-sha256sums=('bcb5076226100f901e6a22656cf69ef0e8d5f1845670e6fad6fc5fdcb3a1dd07'
- 'cd9774272b38183a30275613fd593f0b2de9e18192d2f5c98b26cd4e5cf33d53')
-
-prepare() {
- cd "$srcdir/python_qt_binding-${pkgver}"
- patch -Np1 -i "$srcdir/sip.patch"
-}
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-visualization/python_qt_binding/archive/${pkgver}.tar.gz")
+sha256sums=('bcb5076226100f901e6a22656cf69ef0e8d5f1845670e6fad6fc5fdcb3a1dd07')
build() {
# Use ROS environment variables.