summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ca3342af723
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = roy
+ pkgdesc = With the roy tool you can build custom signature files for siegfried, the signature-based file format identification tool.
+ pkgver = 1.7.4
+ pkgrel = 1
+ url = http://www.itforarchivists.com/siegfried
+ arch = x86_64
+ arch = i686
+ license = APACHE
+ makedepends = git
+ depends = go
+ options = !strip
+ options = !emptydirs
+
+pkgname = roy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4df894a2a496
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Steffen Fritz <aur AT fritz DOT wtf>
+
+pkgname=roy
+pkgver=1.7.4
+pkgrel=1
+pkgdesc="With the roy tool you can build custom signature files for siegfried, the signature-based file format identification tool.
+"
+arch=('x86_64' 'i686')
+url="http://www.itforarchivists.com/siegfried"
+license=('APACHE')
+depends=('go')
+makedepends=('git')
+options=('!strip' '!emptydirs')
+_gourl=github.com/richardlehane/siegfried/cmd/roy
+
+build() {
+ GOPATH="$srcdir" go get ${_gourl}
+}
+
+check() {
+ GOPATH="$GOPATH${GOPATH+:}$srcdir" go test -v -x ${_gourl}
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ install -Dm755 "$srcdir"/bin/roy "$pkgdir"/usr/bin/roy
+}
+
+# vim:set ts=2 sw=2 et: