summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE11
-rw-r--r--PKGBUILD27
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72674899000b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = rpmunpack
+ pkgdesc = This program converts rpm archives to cpio archives for cpio or afio
+ pkgver = 0
+ pkgrel = 3
+ url = http://www.ibiblio.org/pub/Linux/utils/package
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = glibc
+ source = http://www.ibiblio.org/pub/Linux/utils/package/rpmunpack.tar.gz
+ source = LICENSE
+ sha256sums = 4f2e97bdf5cecab2675c63d764b4cf403eb421f887e5abc1e6e41c4767b50ec8
+ sha256sums = deef5b39f2fcdf1951851998107c52e2ae8b98a12289a339f9bf4cced24db0f1
+
+pkgname = rpmunpack
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..3a0aae979a1f
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,11 @@
+Copyright:
+=========
+
+This program has been released into the public domain. You can do whatever
+you like with it. This includes modifying the source, redistributing it etc.
+However, this source code is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+or FITNESS FOR A PARTICULAR PURPOSE. The author cannot be held liable for any
+damage whatsoever produced by the intended or even incorrect use of any part
+of this source code, the resulting binary or any product generated by using
+and/or modifying these sources.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c007ac54588
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Maintainer: Andreas B. Wagner <AndreasBWagner@pointfree.net>
+# Contributor: dale <dale@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname='rpmunpack'
+pkgver='0'
+pkgrel='3'
+pkgdesc='This program converts rpm archives to cpio archives for cpio or afio'
+arch=('i686' 'x86_64')
+url='http://www.ibiblio.org/pub/Linux/utils/package'
+license=('custom')
+depends=('glibc')
+source=("http://www.ibiblio.org/pub/Linux/utils/package/${pkgname}.tar.gz" 'LICENSE')
+sha256sums=('4f2e97bdf5cecab2675c63d764b4cf403eb421f887e5abc1e6e41c4767b50ec8'
+ 'deef5b39f2fcdf1951851998107c52e2ae8b98a12289a339f9bf4cced24db0f1')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -Dm755 'rpmunpack' "${pkgdir}/usr/bin/rpmunpack"
+ install -Dm644 '../LICENSE' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}