summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..10e3f5961926
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = rshell-micropython-git
+ pkgdesc = A remote shell for working with MicroPython boards.
+ pkgver = r134.b87878c
+ pkgrel = 1
+ url = https://github.com/dhylands/rshell
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-pyudev
+ depends = python-pyserial
+ source = rshell-micropython::git+https://github.com/dhylands/rshell.git
+ sha256sums = SKIP
+
+pkgname = rshell-micropython-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe8328f2c083
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Jason Nader <jason nader protonmail com> (replace spaces with dots)
+
+pkgname=rshell-micropython-git
+pkgver=r134.b87878c
+pkgrel=1
+pkgdesc="A remote shell for working with MicroPython boards."
+url="https://github.com/dhylands/rshell"
+depends=('python-pyudev' 'python-pyserial')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("${pkgname%-*}::git+https://github.com/dhylands/rshell.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-*}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+build() {
+ cd "${pkgname%-*}"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname%-*}"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+}