summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD27
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..454a0c0842f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = ruby-apipie-bindings-0.2.2
+ pkgdesc = Bindings for API calls that are documented with Apipie. Bindings are generated on the fly.
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = http://github.com/Apipie/apipie-bindings
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = ruby>=2.0.0
+ depends = ruby-json>=1.2.1
+ depends = ruby-oauth
+ depends = ruby-rest-client>=1.6.5
+ depends = ruby-rest-client<3.0.0
+ provides = ruby-apipie-bindings=0.2.2
+ conflicts = ruby-apipie-bindings
+ noextract = apipie-bindings-0.2.2.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/apipie-bindings-0.2.2.gem
+ sha256sums = 28311bab726abf3d0a39ee6ac4c00278f68abacecb46e71199e14bb6c2053fa0
+
+pkgname = ruby-apipie-bindings-0.2.2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fab0108d3566
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer Valantin <valantin89 [at] gmail [dot] com>
+
+_gemname=apipie-bindings
+_pkgname=ruby-$_gemname
+pkgver=0.2.2
+pkgname=$_pkgname-$pkgver
+pkgrel=1
+pkgdesc='Bindings for API calls that are documented with Apipie. Bindings are generated on the fly.'
+arch=(i686 x86_64)
+url='http://github.com/Apipie/apipie-bindings'
+license=(MIT)
+depends=('ruby>=2.0.0'
+ 'ruby-json>=1.2.1'
+ 'ruby-oauth'
+ 'ruby-rest-client>=1.6.5' 'ruby-rest-client<3.0.0')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+options=(!emptydirs)
+source=("https://rubygems.org/downloads/${_gemname}-${pkgver}.gem")
+noextract=($_gemname-$pkgver.gem)
+sha256sums=('28311bab726abf3d0a39ee6ac4c00278f68abacecb46e71199e14bb6c2053fa0')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install --no-document -i "${pkgdir}/${_gemdir}" -n "${pkgdir}/usr/bin" $_gemname-$pkgver.gem
+ rm "${pkgdir}/${_gemdir}/cache/${_gemname}-${pkgver}.gem"
+}