summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a9c2f1ca9649
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ruby-filesize
+ pkgdesc = filesize is a small class for handling filesizes with both the SI and binary prefixes, allowing conversion from any size to any other size.
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/dominikh/filesize
+ arch = any
+ license = MIT
+ depends = ruby
+ noextract = filesize-0.2.0.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/filesize-0.2.0.gem
+ sha1sums = 2a88f34ce629bdcb00113a6cf4128a61e10d0814
+
+pkgname = ruby-filesize
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c61587240dbb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Generated by gem2arch (https://github.com/anatol/gem2arch)
+# Maintainer: Florian Maunier <fmauneko@dissidence.ovh>
+
+_gemname=filesize
+pkgname=ruby-$_gemname
+pkgver=0.2.0
+pkgrel=1
+pkgdesc='filesize is a small class for handling filesizes with both the SI and binary prefixes, allowing conversion from any size to any other size.'
+arch=(any)
+url='https://github.com/dominikh/filesize'
+license=(MIT)
+depends=(ruby)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha1sums=('2a88f34ce629bdcb00113a6cf4128a61e10d0814')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}