summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68b7ce285314
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ruby-gir_ffi
+ pkgdesc = FFI-based GObject binding using the GObject Introspection Repository
+ pkgver = 0.10.2
+ pkgrel = 1
+ url = http://www.github.com/mvz/ruby-gir-ffi
+ arch = any
+ license = LGPL2.1
+ depends = gobject-introspection-runtime
+ depends = ruby
+ depends = ruby-ffi-bit_masks
+ depends = ruby-indentation
+ noextract = gir_ffi-0.10.2.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/gir_ffi-0.10.2.gem
+ sha1sums = 9a30ec50e82ecba934bc34076ccf3aea08e5906e
+
+pkgname = ruby-gir_ffi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..812189a74d39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Generated by gem2arch (https://github.com/anatol/gem2arch)
+# Contributor: Rhys <rhys@johnguant.com>
+
+_gemname=gir_ffi
+pkgname=ruby-$_gemname
+pkgver=0.10.2
+pkgrel=1
+pkgdesc='FFI-based GObject binding using the GObject Introspection Repository'
+arch=(any)
+url='http://www.github.com/mvz/ruby-gir-ffi'
+license=(LGPL2.1)
+depends=(gobject-introspection-runtime ruby ruby-ffi-bit_masks ruby-indentation)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha1sums=('9a30ec50e82ecba934bc34076ccf3aea08e5906e')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/COPYING.LIB" "$pkgdir/usr/share/licenses/$pkgname/COPYING.LIB"
+}