summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4bbd4cdeed24
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ruby-i3ipc
+ pkgdesc = Interprocess communication with i3 wm
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/veelenga/i3ipc-ruby
+ arch = any
+ license = MIT
+ depends = ruby
+ noextract = i3ipc-0.2.0.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/i3ipc-0.2.0.gem
+ sha1sums = e2c4c9d48effa3d6244fff8f763e764656f92885
+
+pkgname = ruby-i3ipc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1f260664ae8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Generated by gem2arch (https://github.com/anatol/gem2arch)
+# Maintainer: Daniel Wiesendorf <daniel.wiesendorf@googlemail.com>
+
+_gemname=i3ipc
+pkgname=ruby-$_gemname
+pkgver=0.2.0
+pkgrel=1
+pkgdesc='Interprocess communication with i3 wm'
+arch=(any)
+url='https://github.com/veelenga/i3ipc-ruby'
+license=(MIT)
+depends=(ruby)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha1sums=('e2c4c9d48effa3d6244fff8f763e764656f92885')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+}