summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--disable-simplecov-lcov.patch30
3 files changed, 30 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3f84f95f139..20d0beb90a8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ruby-process_executer
pkgdesc = An API for executing commands in a subprocess
- pkgver = 1.1.0
+ pkgver = 1.3.0
pkgrel = 1
url = https://github.com/main-branch/process_executer
arch = any
@@ -12,9 +12,9 @@ pkgbase = ruby-process_executer
makedepends = ruby-rdoc
depends = ruby
options = !emptydirs
- source = process_executer-1.1.0.tar.gz::https://github.com/main-branch/process_executer/archive/refs/tags/v1.1.0.tar.gz
+ source = process_executer-1.3.0.tar.gz::https://github.com/main-branch/process_executer/archive/refs/tags/v1.3.0.tar.gz
source = disable-simplecov-lcov.patch
- sha256sums = f0708822cd2b680b988b485203eaff644db165d2bb509026956549341747d04f
- sha256sums = 15aff615d2f63dbda8239b61ac9b03b6fb474d188f098b9b0de52af56fecc44c
+ sha256sums = 995e95c4343d5d10fdb9604e8859bea2b0370af8bd21d79da6c944cd8cb94fec
+ sha256sums = 0466fa05ad1ca828035cabe2558de7dc2a285eb7e46dd0b21ee22c3c128dd598
pkgname = ruby-process_executer
diff --git a/PKGBUILD b/PKGBUILD
index 24d07e383d31..caddeb558cfc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_gemname=process_executer
pkgname=ruby-$_gemname
-pkgver=1.1.0
+pkgver=1.3.0
pkgrel=1
pkgdesc="An API for executing commands in a subprocess"
arch=(any)
@@ -14,8 +14,8 @@ makedepends=(rubygems ruby-rdoc)
options=(!emptydirs)
source=(${_gemname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz
disable-simplecov-lcov.patch)
-sha256sums=('f0708822cd2b680b988b485203eaff644db165d2bb509026956549341747d04f'
- '15aff615d2f63dbda8239b61ac9b03b6fb474d188f098b9b0de52af56fecc44c')
+sha256sums=('995e95c4343d5d10fdb9604e8859bea2b0370af8bd21d79da6c944cd8cb94fec'
+ '0466fa05ad1ca828035cabe2558de7dc2a285eb7e46dd0b21ee22c3c128dd598')
prepare() {
cd "${_gemname}-${pkgver}"
@@ -80,7 +80,7 @@ package() {
cp --archive --verbose tmp_install/* "${pkgdir}"
- install -Dm0644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm0644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm0644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
}
diff --git a/disable-simplecov-lcov.patch b/disable-simplecov-lcov.patch
index cffbeba5b23c..6ba1e22e494d 100644
--- a/disable-simplecov-lcov.patch
+++ b/disable-simplecov-lcov.patch
@@ -1,16 +1,30 @@
diff --git a/spec/spec_helper.rb b/spec/spec_helper.rb
-index 5f54fbc..e24fc81 100644
+index e5d00d1..4704650 100644
--- a/spec/spec_helper.rb
+++ b/spec/spec_helper.rb
-@@ -15,10 +15,9 @@ end
- # Setup simplecov
-
+@@ -30,25 +30,17 @@ end
+ # SimpleCov configuration
+ #
require 'simplecov'
-require 'simplecov-lcov'
- require 'json'
+-require 'simplecov-rspec'
+
+ def ci_build? = ENV.fetch('GITHUB_ACTIONS', 'false') == 'true'
+
+ if ci_build?
+ SimpleCov.formatters = [
+ SimpleCov::Formatter::HTMLFormatter,
+- SimpleCov::Formatter::LcovFormatter
+ ]
+ end
--SimpleCov.formatters = [SimpleCov::Formatter::HTMLFormatter, SimpleCov::Formatter::LcovFormatter]
-+SimpleCov.formatters = [SimpleCov::Formatter::HTMLFormatter]
+ require 'rbconfig'
- # Report if the test coverage was below the configured threshold
+-SimpleCov::RSpec.start(list_uncovered_lines: ci_build?) do
+- # Avoid false positives in spec directory from JRuby, TruffleRuby, and Windows
+- add_filter '/spec/' unless RUBY_ENGINE == 'ruby' && !Gem.win_platform?
+-end
+-
+ # Make sure to require your project AFTER starting SimpleCov
#
+ require 'process_executer'