summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73b533ff26e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Wed Sep 7 11:55:22 UTC 2016
+pkgbase = ruby-semantic_puppet
+ pkgdesc = Library of useful tools for working with Semantic Versions and module dependencies.
+ pkgver = 0.1.4
+ pkgrel = 1
+ url = https://github.com/puppetlabs/semantic_puppet
+ arch = any
+ license = Apache-2.0
+ depends = ruby
+ depends = ruby-gettext-setup
+ noextract = semantic_puppet-0.1.4.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/semantic_puppet-0.1.4.gem
+ sha256sums = 6c9236fba9e547b43ac35f700506f5df1975905e98a18821ffc28ded754e41ff
+
+pkgname = ruby-semantic_puppet
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba396886b4d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mario Finelli <mario at finel dot li>
+
+_gemname=semantic_puppet
+pkgname=ruby-$_gemname
+pkgver=0.1.4
+pkgrel=1
+pkgdesc='Library of useful tools for working with Semantic Versions and module dependencies.'
+arch=(any)
+url='https://github.com/puppetlabs/semantic_puppet'
+license=('Apache-2.0')
+depends=(ruby ruby-gettext-setup)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha256sums=('6c9236fba9e547b43ac35f700506f5df1975905e98a18821ffc28ded754e41ff')
+
+package() {
+ cd "$srcdir"
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+}