summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 34 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c66ba20037..99d557b10d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,27 @@
-# Generated by mksrcinfo v8
-# Sun Jan 15 23:12:27 UTC 2017
pkgbase = ruby-twitter
pkgdesc = A Ruby interface to the Twitter API.
- pkgver = 6.0.0
+ pkgver = 6.2.0
pkgrel = 1
url = http://sferik.github.io/twitter/
arch = any
license = MIT
+ makedepends = rubygems
+ makedepends = ruby-rdoc
depends = ruby
depends = ruby-addressable
depends = ruby-buftok
depends = ruby-equalizer
- depends = ruby-faraday
depends = ruby-http
+ depends = ruby-http-form_data
depends = ruby-http_parser.rb
- depends = ruby-json
depends = ruby-memoizable
+ depends = ruby-multipart-post
depends = ruby-naught
depends = ruby-simple_oauth
- noextract = twitter-6.0.0.gem
+ noextract = twitter-6.2.0.gem
options = !emptydirs
- source = https://rubygems.org/downloads/twitter-6.0.0.gem
- sha256sums = c5e9eb87d222532c556c92e57d2812ef9ee5afb80c9e6c4f392b5bfeff0d0dc2
+ source = https://rubygems.org/downloads/twitter-6.2.0.gem
+ sha256sums = c5a2d2c33d67f689d88bdf6a194ae50eaef63e0a4da9d48aeee32f15f7f85e3a
pkgname = ruby-twitter
diff --git a/PKGBUILD b/PKGBUILD
index 9cf2be7916c..bf0adab8540 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,42 @@
-# Maintainer: Mario Finelli <mario dot finelli at yahoo dot com>
+# Maintainer: Mario Finelli <mario at finel dot li>
_gemname=twitter
pkgname=ruby-$_gemname
-pkgver=6.0.0
+pkgver=6.2.0
pkgrel=1
pkgdesc='A Ruby interface to the Twitter API.'
arch=(any)
url='http://sferik.github.io/twitter/'
license=(MIT)
-depends=(ruby ruby-addressable ruby-buftok ruby-equalizer ruby-faraday ruby-http ruby-http_parser.rb ruby-json ruby-memoizable ruby-naught ruby-simple_oauth)
+depends=(ruby
+ ruby-addressable
+ ruby-buftok
+ ruby-equalizer
+ ruby-http
+ ruby-http-form_data
+ ruby-http_parser.rb
+ ruby-memoizable
+ ruby-multipart-post
+ ruby-naught
+ ruby-simple_oauth)
+makedepends=(rubygems ruby-rdoc)
options=(!emptydirs)
source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
-sha256sums=('c5e9eb87d222532c556c92e57d2812ef9ee5afb80c9e6c4f392b5bfeff0d0dc2')
+sha256sums=('c5a2d2c33d67f689d88bdf6a194ae50eaef63e0a4da9d48aeee32f15f7f85e3a')
package() {
- cd "$srcdir"
local _gemdir="$(ruby -e'puts Gem.default_dir')"
- gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ gem install \
+ --ignore-dependencies \
+ --no-user-install \
+ -i "$pkgdir/$_gemdir" \
+ -n "$pkgdir/usr/bin" \
+ $_gemname-$pkgver.gem
+
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+
+ install -Dm0644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE.md" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}