summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b609200c046
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ruby-xapian-full
+ pkgdesc = xapian-core + Ruby xapian-bindings
+ pkgver = 1.2.3
+ pkgrel = 1
+ url = https://rubygems.org/gems/xapian-full
+ arch = i686
+ arch = x86_64
+ depends = ruby
+ noextract = xapian-full-1.2.3.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/xapian-full-1.2.3.gem
+ sha512sums = f69d0020a6d56ae3e01db476ca7a6822635669cb669a2d5ea2ee01567de670d321f4fb7f6aa3eeff73bca7dde18accd022331bab9b05efb4f48b034b58fa1aca
+
+pkgname = ruby-xapian-full
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4560d85524c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Generated by gem2arch (https://github.com/anatol/gem2arch)
+# Maintainer: Artem Vorotnikov <artem@vorotnikov.me>
+
+_gemname=xapian-full
+pkgname=ruby-$_gemname
+pkgver=1.2.3
+pkgrel=1
+pkgdesc='xapian-core + Ruby xapian-bindings'
+arch=(i686 x86_64)
+url='https://rubygems.org/gems/xapian-full'
+license=()
+depends=(ruby)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha512sums=('f69d0020a6d56ae3e01db476ca7a6822635669cb669a2d5ea2ee01567de670d321f4fb7f6aa3eeff73bca7dde18accd022331bab9b05efb4f48b034b58fa1aca')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+}