summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD28
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..281199fa79ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = runner
+ pkgdesc = A script to execut files
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = https://github.com/Johnson170/runner
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ source = /runner-0.0.2::git+https://github.com/Johnson170/runner.git
+ md5sums = SKIP
+
+pkgname = runner
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dfd77cb810c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: 潘一萱 <1138401083@qq.com>
+pkgname=runner
+pkgver=0.0.2
+pkgrel=1
+pkgdesc="A script to execut files"
+arch=('x86_64')
+url="https://github.com/Johnson170/runner"
+license=('GPL')
+makedepends=('git')
+source=("$srcdir/$pkgname-$pkgver::git+https://github.com/Johnson170/runner.git")
+md5sums=("SKIP")
+
+
+build() {
+ cd "$pkgname-$pkgver"
+ chmod u+x runner.sh
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ sudo cp runner.sh /usr/bin/runner
+ sudo chmod 755 /usr/bin/runner
+}