summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dcb2d791b55f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = runningx
+ pkgdesc = A simple C program which uses an X call to determine if X is running
+ pkgver = 20101203
+ pkgrel = 1
+ url = http://www.fiction.net/blong/programs/mutt/
+ arch = any
+ license = unknown
+ depends = libx11
+ source = http://www.fiction.net/blong/programs/mutt/autoview/RunningX.c
+ md5sums = 31fa80ae98c0fefe11e4786b2d7e4e79
+
+pkgname = runningx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f13f16a29ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Darshit Shah <darnir@gmail.com>
+# Contributor: Dieter Plaetinck <dieter@plaetinck.be>
+
+pkgname=runningx
+pkgver=20101203
+pkgrel=1
+pkgdesc="A simple C program which uses an X call to determine if X is running"
+
+arch=('any')
+url="http://www.fiction.net/blong/programs/mutt/"
+license=('unknown')
+depends=('libx11')
+source=('http://www.fiction.net/blong/programs/mutt/autoview/RunningX.c')
+md5sums=('31fa80ae98c0fefe11e4786b2d7e4e79')
+
+package() {
+ cd $srcdir || return 1
+ gcc -o RunningX RunningX.c -lX11
+ mkdir -p $pkgdir/usr/bin/
+ cp RunningX $pkgdir/usr/bin/runningx
+}
+# vim:set ts=2 sw=2 et: