summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0fb754960142..2f2bb0fac38f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,12 +24,14 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$_pkgname"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
build() {
cd "$_pkgname"
- rustup set profile minimal
- rustup default nightly-2020-07-21
- cargo build --release --locked
+ cargo build --release --frozen
}
package() {