summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3794e88e9dc..05f96ccb2197 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = rustop-git
pkgdesc = All important information about your system in one place
pkgver = 20200506.d134a9a
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/wojciechkepka/rustop
arch = x86_64
arch = i686
license = MIT
makedepends = cargo
makedepends = git
+ makedepends = help2man
provides = rustop
conflicts = rustop
source = rustop-git::git+https://github.com/wojciechkepka/rustop
diff --git a/PKGBUILD b/PKGBUILD
index cc543c754bbc..bf2ee4d06906 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Wojciech Kepka <wojtek.kepka@protonmail.com>
pkgname=rustop-git
pkgver=20200506.d134a9a
-pkgrel=2
+pkgrel=3
epoch=
pkgdesc="All important information about your system in one place"
arch=('x86_64' 'i686')
url="https://github.com/wojciechkepka/rustop"
license=('MIT')
depends=()
-makedepends=('cargo' 'git')
+makedepends=('cargo' 'git' 'help2man' )
provides=("rustop")
conflicts=("rustop")
sha1sums=('SKIP')
@@ -17,6 +17,7 @@ source=("$pkgname::git+https://github.com/wojciechkepka/rustop")
build() {
cd "$pkgname"
cargo build --release
+ help2man target/release/rustop > target/release/rustop.1
}
pkgver() {
@@ -29,4 +30,5 @@ package() {
install -Dm755 "target/release/rustop" "$pkgdir/usr/bin/rustop"
install -Dm644 "README.md" "$pkgdir/usr/share/doc/${pkgname}/README.md"
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "target/release/rustop.1" "$pkgdir/usr/share/man/man1/rustop.1"
}