summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD63
-rw-r--r--sakura-bzr.install13
4 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..62f3a04417c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = sakura-bzr
+ pkgdesc = A terminal emulator based on GTK and VTE
+ pkgver = 492
+ pkgrel = 1
+ url = https://launchpad.net/sakura
+ install = sakura-bzr.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = bzr
+ depends = vte290
+ depends = libxft
+ depends = desktop-file-utils
+ provides = sakura
+ conflicts = sakura
+ source = sakura-bzr::bzr+https://launchpad.net/sakura/trunk
+ sha256sums = SKIP
+
+pkgname = sakura-bzr
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..17dfc966d052
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg
+src
+*.tar.??
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81881c3ff7c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Evan Pitstick <nerdx00 NOSPAM gmail DOT com>
+# Based on: https://www.archlinux.org/packages/community/x86_64/sakura/
+
+pkgname=sakura-bzr
+_name=sakura
+pkgver=492
+pkgrel=1
+pkgdesc="A terminal emulator based on GTK and VTE"
+arch=('i686' 'x86_64')
+url="https://launchpad.net/sakura"
+license=('GPL')
+depends=('vte290' 'libxft' 'desktop-file-utils')
+makedepends=('cmake' 'bzr')
+provides=('sakura')
+conflicts=('sakura')
+install=${pkgname}.install
+source=(
+ "${pkgname}::bzr+https://launchpad.net/${_name}/trunk"
+)
+sha256sums=(
+ 'SKIP'
+)
+
+pkgver() {
+
+ cd ${srcdir}/${pkgname}
+ bzr revno
+
+}
+
+prepare() {
+
+ cd ${srcdir}/${pkgname}
+
+ # Set default font to something more generic
+ sed -i 's|#define DEFAULT_FONT "Ubuntu Mono,monospace 13"|#define DEFAULT_FONT "Monospace 10"|g' \
+ src/sakura.c
+
+}
+
+build() {
+
+ cd ${srcdir}/${pkgname}
+
+ # build & install
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+
+}
+
+package() {
+
+ cd ${srcdir}/${pkgname}
+
+ make DESTDIR=${pkgdir} install
+ # extract the keybindings from the installed documentation, rest is only relevant during build time
+ awk '/^Keybindings/{f="'${pkgdir}'/usr/share/doc/'${_name}'/KEYBINDINGS"} f{print > f} /^END/' \
+ ${pkgdir}/usr/share/doc/${_name}/INSTALL
+ rm ${pkgdir}/usr/share/doc/${_name}/INSTALL
+
+}
+
+# vim: ts=4 sts=4 sw=4 noet
diff --git a/sakura-bzr.install b/sakura-bzr.install
new file mode 100644
index 000000000000..93d744b1d365
--- /dev/null
+++ b/sakura-bzr.install
@@ -0,0 +1,13 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ update-desktop-database -q
+}
+
+# vim: ts=4 sts=4 sw=4 noet