summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD25
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41a6f2548e79
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = sapulatar-qt
+ pkgdesc = A simple gui apps to help you remove background from various images.
+ pkgver = 1.0.dev1
+ pkgrel = 1
+ url = https://github.com/devlovers-id/sapulatar-qt
+ arch = any
+ license = GPLv3
+ makedepends = python-setuptools
+ depends = pyside2
+ depends = python
+ source = sapulatar-qt::git+https://github.com/devlovers-id/sapulatar-qt
+ sha256sums = SKIP
+
+pkgname = sapulatar-qt
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..25b1b36ca48a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.xz
+*.tar.gz
+pkg/
+src/
+sapulatar-qt/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e04c7532189
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: M Nabil Adani <nblid48[at]gmail[dot]com>
+
+pkgname=sapulatar-qt
+pkgver=1.0.dev1
+pkgrel=1
+pkgdesc='A simple gui apps to help you remove background from various images.'
+arch=('any')
+url="https://github.com/devlovers-id/sapulatar-qt"
+license=('GPLv3')
+makedepends=('python-setuptools')
+depends=('pyside2' 'python')
+source=("${pkgname}::git+https://github.com/devlovers-id/sapulatar-qt")
+sha256sums=('SKIP')
+
+# pkgver(){
+# cd "${pkgname}"
+# git describe --long | cut -d "-" -f 1
+# }
+
+package() {
+ cd "$srcdir/$pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+