summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 12 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e737b60c189..88d4d9deaa76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = saw-script-git
- pkgdesc = The SAW scripting language.
- pkgver = ef1f6549
+ pkgdesc = The Software Analysis Workbench
+ pkgver = r2688.75c7fd76
pkgrel = 1
- url = http://saw.galois.com/
+ url = https://saw.galois.com/
arch = x86_64
license = noncommercial
makedepends = stack
@@ -12,7 +12,7 @@ pkgbase = saw-script-git
provides = saw-script
conflicts = saw-script
source = git://github.com/GaloisInc/saw-script.git
- md5sums = SKIP
+ sha1sums = SKIP
pkgname = saw-script-git
diff --git a/PKGBUILD b/PKGBUILD
index 0d5d34561eb5..df6531c8a8cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,26 @@
# Maintainer: Brent Carmer <bcarmer@gmail.com>
+# Co-maintainer: Alex J. Malozemoff <amaloz@galois.com>
+
pkgname=saw-script-git
_pkgname=saw-script
-pkgver=ef1f6549
+pkgver=r2688.75c7fd76
pkgver() {
- cd "$_pkgname"
- git describe --long --tags --always | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
pkgrel=1
-pkgdesc="The SAW scripting language."
-url="http://saw.galois.com/"
+pkgdesc="The Software Analysis Workbench"
+url="https://saw.galois.com/"
arch=('x86_64')
license=('noncommercial')
depends=('ncurses' 'z3')
makedepends=('stack' 'perl')
-optdepends=()
-conflicts=()
-replaces=()
-backup=()
conflicts=('saw-script')
provides=('saw-script')
-md5sums=('SKIP')
-
source=('git://github.com/GaloisInc/saw-script.git')
+sha1sums=('SKIP')
build() {
cd "$srcdir/${_pkgname}"