summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD13
-rw-r--r--fix_gimp2.9.patch11
4 files changed, 26 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06d3eb73979f..163ceeecf70d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = scangearmp-mp280
pkgdesc = Canon Scanner Driver (mp280 series)
pkgver = 1.60
- pkgrel = 4
+ pkgrel = 5
url = http://support-my.canon-asia.com/contents/MY/EN/0100303302.html
arch = i686
arch = x86_64
@@ -17,9 +17,10 @@ pkgbase = scangearmp-mp280
source = http://gdlp01.c-wss.com/gds/3/0100003033/01/scangearmp-source-1.60-1.tar.gz
source = fix_png15.patch
source = fix_configure.patch
+ source = fix_gimp2.9.patch
md5sums = 15782d670f9d5c5904e00610508114f3
md5sums = 6609d7fe171e67451658a3665442972c
md5sums = 8c21b22ef834b17bcdad6e97d8916ca2
+ md5sums = f90572fce7a3878438f7c93360f615e4
pkgname = scangearmp-mp280
-
diff --git a/.gitignore b/.gitignore
index a6b5e5e85edd..8c1fdf1fa889 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,7 @@
/pkg/
/src/
*.pkg.tar.xz
+*.pkg.tar.zst
*.pkg.tar.xz.sig
+*.pkg.tar.zst.sig
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 1ccbfd34512f..d5948a955ce2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Jakub Klinkovský <kuba.klinkovsky@gmail.com>
+# Maintainer: Muhammad Hidayat <hidayat.pcd@gmail.com>
+# Former maintainer: Jakub Klinkovský <kuba.klinkovsky@gmail.com>
#
# If you're going to adapt this package to other printer models,
# here is a list of printer names and IDs:
@@ -19,7 +20,7 @@ _id=370
pkgname=scangearmp-${_name}
pkgver=1.60
-pkgrel=4
+pkgrel=5
_pkgver=1.60-1
pkgdesc="Canon Scanner Driver (${_name} series)"
url="http://support-my.canon-asia.com/contents/MY/EN/0100303302.html"
@@ -39,10 +40,13 @@ makedepends=(
)
source=(http://gdlp01.c-wss.com/gds/3/0100003033/01/scangearmp-source-${_pkgver}.tar.gz
fix_png15.patch
- fix_configure.patch)
+ fix_configure.patch
+ fix_gimp2.9.patch
+)
md5sums=('15782d670f9d5c5904e00610508114f3'
'6609d7fe171e67451658a3665442972c'
- '8c21b22ef834b17bcdad6e97d8916ca2')
+ '8c21b22ef834b17bcdad6e97d8916ca2'
+ 'f90572fce7a3878438f7c93360f615e4')
if [ "$CARCH" == "x86_64" ]; then
_libdir=libs_bin64
@@ -55,6 +59,7 @@ build() {
cd "$srcdir/scangearmp-source-$_pkgver"
patch -p1 -i "$srcdir/fix_png15.patch"
patch -p1 -i "$srcdir/fix_configure.patch"
+ patch -p1 -i "$srcdir/fix_gimp2.9.patch"
# Prepare build
cd "$srcdir/scangearmp-source-$_pkgver/scangearmp"
diff --git a/fix_gimp2.9.patch b/fix_gimp2.9.patch
new file mode 100644
index 000000000000..84bf2854c8d3
--- /dev/null
+++ b/fix_gimp2.9.patch
@@ -0,0 +1,11 @@
+--- a/scangearmp/src/scangimp.c 2010-05-25 19:13:09.000000000 +0800
++++ b/scangearmp/src/scangimp.c 2021-10-19 20:25:23.125174785 +0800
+@@ -43,7 +43,7 @@
+ //#include <string.h>
+ //#include <gtk/gtk.h>
+ #include <libgimp/gimp.h>
+-#include <libgimp/gimpcompat.h>
++//#include <libgimp/gimpcompat.h>
+ #include <dlfcn.h>
+
+ #include "cnmstype.h"