summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f677bdd4423
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = scim-pinyin
+ pkgdesc = Chinese pinyin input for SCIM
+ pkgver = 0.5.92
+ pkgrel = 4
+ url = https://www.scim-im.org/
+ arch = x86_64
+ license = GPL
+ depends = scim
+ source = https://downloads.sourceforge.net/sourceforge/scim/scim-pinyin-0.5.92.tar.xz
+ sha256sums = 30cb1d24db913bfe239429f3421b7b4e0bdf09d7410346f19b49322321c362f2
+
+pkgname = scim-pinyin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7b2d2604807
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Contributer: Gan Lu <rhythm.gan@gmail.com>
+
+pkgname=scim-pinyin
+pkgver=0.5.92
+pkgrel=4
+pkgdesc='Chinese pinyin input for SCIM'
+url='https://www.scim-im.org/'
+arch=('x86_64')
+license=('GPL')
+depends=('scim')
+source=("https://downloads.sourceforge.net/sourceforge/scim/${pkgname}-${pkgver}.tar.xz")
+sha256sums=('30cb1d24db913bfe239429f3421b7b4e0bdf09d7410346f19b49322321c362f2')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}