summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD50
2 files changed, 30 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fd2e839d8cb..406daa935dfc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,26 @@
pkgbase = scratch-desktop
pkgdesc = Create and share your own interactive stories, games, music and art
- pkgver = 3.28.0
+ pkgver = 3.29.1
pkgrel = 1
url = https://scratch.mit.edu
arch = x86_64
license = GPL
- makedepends = electron11
+ makedepends = electron19
depends = c-ares
depends = ffmpeg
depends = gtk3
- depends = http-parser
depends = libevent
- depends = libnghttp2
depends = libxslt
depends = minizip
depends = nss
depends = re2
depends = snappy
- source = scratch.exe::https://downloads.scratch.mit.edu/desktop/Scratch%203.28.0%20Setup.exe
+ options = !strip
+ source = scratch.exe::https://downloads.scratch.mit.edu/desktop/Scratch%20Setup.exe
source = https://scratch.mit.edu/images/download/icon.png
source = scratch-desktop.desktop
source = x-scratch.xml
- sha256sums = 03037e3e4c5227c496dfc9d905e59bb3308c8ce82aec11d545cdd75145da18a2
+ sha256sums = dfca2f1a842aea69a2b0a22ca66fa7852f86259e3da4f576f8ae7fa16f1e9134
sha256sums = 5efbe1a31e973d0393631e0317f68f81d213b6c55434b9f9185a47554f23ed99
sha256sums = 73d4f255aee28b9f72764a55e8711d07826e037ec624d23c8f7e7764c10475d5
sha256sums = 1090a96c91f7a47801633e077717b730d636f53bac7f8958c9fc9595ee5dba7e
diff --git a/PKGBUILD b/PKGBUILD
index b79099193a8d..eb3e59e32338 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,50 @@
# Maintainer: Xiaotian Wu <yetist@gmail.com>
pkgname=scratch-desktop
-pkgver=3.28.0
+pkgver=3.29.1
pkgrel=1
pkgdesc="Create and share your own interactive stories, games, music and art"
url="https://scratch.mit.edu"
arch=('x86_64')
license=('GPL')
-depends=('c-ares' 'ffmpeg' 'gtk3' 'http-parser' 'libevent' 'libnghttp2'
- 'libxslt' 'minizip' 'nss' 're2' 'snappy')
-makedepends=('electron11')
-source=("scratch.exe::https://downloads.scratch.mit.edu/desktop/Scratch%20${pkgver}%20Setup.exe"
+depends=('c-ares' 'ffmpeg' 'gtk3' 'libevent' 'libxslt' 'minizip' 'nss' 're2'
+ 'snappy')
+makedepends=('electron19')
+options=(!strip)
+source=("scratch.exe::https://downloads.scratch.mit.edu/desktop/Scratch%20Setup.exe"
'https://scratch.mit.edu/images/download/icon.png'
'scratch-desktop.desktop'
'x-scratch.xml'
)
-sha256sums=('03037e3e4c5227c496dfc9d905e59bb3308c8ce82aec11d545cdd75145da18a2'
+sha256sums=('dfca2f1a842aea69a2b0a22ca66fa7852f86259e3da4f576f8ae7fa16f1e9134'
'5efbe1a31e973d0393631e0317f68f81d213b6c55434b9f9185a47554f23ed99'
'73d4f255aee28b9f72764a55e8711d07826e037ec624d23c8f7e7764c10475d5'
'1090a96c91f7a47801633e077717b730d636f53bac7f8958c9fc9595ee5dba7e')
-build() {
- cp -rf /usr/lib/electron11/* .
- rm $srcdir/*.dll
- rm $srcdir/*.exe
- ln -fsr electron scratch-desktop
-}
-
package() {
- install -d ${pkgdir}/usr/lib/scratch-desktop
- cp -rf locales/ resources/ swiftshader/ ${pkgdir}/usr/lib/scratch-desktop
- cp lib* ${pkgdir}/usr/lib/scratch-desktop
- cp *.pak *.bin *.dat *.json ${pkgdir}/usr/lib/scratch-desktop
- cp chrome-sandbox electron version ${pkgdir}/usr/lib/scratch-desktop
- ln -sf electron ${pkgdir}/usr/lib/scratch-desktop/scratch-desktop
+ cd "$srcdir"
- install -d ${pkgdir}/usr/share/licenses/scratch-desktop
- cp LICENSE* ${pkgdir}/usr/share/licenses/scratch-desktop
+ # Install electron
+ install -d ${pkgdir}/usr/lib/${pkgname}
+ cp -r /usr/lib/electron19/* ${pkgdir}/usr/lib/${pkgname}
+ rm -f ${pkgdir}/usr/lib/${pkgname}/resources/default_app.asar
+ # Create symlink for command
install -d ${pkgdir}/usr/bin
- ln -sf /usr/lib/scratch-desktop/scratch-desktop ${pkgdir}/usr/bin/scratch-desktop
+ ln -fs electron ${pkgdir}/usr/lib/${pkgname}/scratch-desktop
+ ln -fs /usr/lib/${pkgname}/scratch-desktop ${pkgdir}/usr/bin/scratch-desktop
+ # Install desktop file
+ install -Dm644 scratch-desktop.desktop -t ${pkgdir}/usr/share/applications/
install -Dm644 icon.png ${pkgdir}/usr/share/pixmaps/scratch-desktop.png
- install -Dm644 resources/static/assets/0fb9be3e8397c983338cb71dc84d0b25.svg ${pkgdir}/usr/share/icons/hicolor/scalable/mimetypes/scratch-sprite.svg
- install -Dm644 scratch-desktop.desktop ${pkgdir}/usr/share/applications/scratch-desktop.desktop
+ # app.asar and static
+ cd resources
+ rm -f elevate.exe
+ find . -type d -exec install -d {,"$pkgdir"/usr/lib/${pkgname}/resources/}{} \;
+ find . -type f -exec install -D {,"$pkgdir"/usr/lib/${pkgname}/resources/}{} \;
- install -Dm644 x-scratch.xml ${pkgdir}/usr/share/mime/packages/x-scratch.xml
+ # Mimetype
+ install -Dm644 static/assets/0fb9be3e8397c983338cb71dc84d0b25.svg ${pkgdir}/usr/share/icons/hicolor/scalable/mimetypes/scratch-sprite.svg
+ install -Dm644 ${srcdir}/x-scratch.xml -t ${pkgdir}/usr/share/mime/packages/
}