summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore18
-rw-r--r--PKGBUILD50
-rwxr-xr-xscratch26
-rw-r--r--scratch2.desktop8
-rw-r--r--scratch2.pngbin8208 -> 0 bytes
-rw-r--r--scratch2.xml17
-rw-r--r--scratchLocalData.solbin0 -> 84 bytes
-rw-r--r--x-scratch2-project.pngbin10445 -> 0 bytes
9 files changed, 65 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d44944638a0c..67c605b880fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,26 @@
-# Generated by mksrcinfo v8
-# Mon Nov 6 09:07:42 UTC 2017
pkgbase = scratch2
- pkgdesc = With Scratch, you can program your own interactive stories, games, and animations
- pkgver = 2.0.458.0.1
+ pkgdesc = Create stories, games, and animations, share with others around the world
+ pkgver = 2.0.461
pkgrel = 1
- url = https://scratch.mit.edu
+ url = https://scratch.mit.edu/
arch = any
license = GPL
makedepends = unzip
- depends = adobe-air
+ depends = adobe-air-sdk
depends = libxt
depends = libxtst
depends = alsa-lib
- noextract = Scratch-458.0.1.air
- source = https://download.scratch.mit.edu/scratch2download/sa/Scratch-458.0.1.air
+ noextract = Scratch-461.air
+ source = https://scratch.mit.edu/scratchr2/static/sa/Scratch-461.air
+ source = scratch2
source = scratch2.desktop
- source = scratch2.png
source = scratch2.xml
- source = x-scratch2-project.png
- sha1sums = c5c9c19fb1ac57ecb7d03e4ad0d663a77e8e396c
- sha1sums = 24d3849d3e38836b0b116a2e620a173f1770f13b
- sha1sums = bfca77daa1a9079f2197d98509ca4a33b3246df1
- sha1sums = 2d45707fd12c709e21fa74b85f6c7b7dfe0d47a2
- sha1sums = 211b6b6ca9e987327632446f1bb15908babbcfae
+ source = scratchLocalData.sol
+ sha512sums = cc0d98bcc90540a5b913941f57f21e87ea1bb4468260a2cb66c9688a9c25bbe4081ace6370fd2d9f66cfc8877ca5664de1e7efede7afdce004af840b71bbc46f
+ sha512sums = 378551bee811e16a1139139b78d0f4e0471c67c5e1076eaaf2e137378bc44e7e3b55788fe58681da44ea8d359c6ce343f0729b2aa80dbbbd695954c3efb1515a
+ sha512sums = e32fd12f4fbb35fa7c60d658a83d0186424c404a89064bc16f1c7df501bc325e77bdfa2f9fb291ccdd42bd4ca96fb8c51b282194d058f2b7e25b552c86f34b0f
+ sha512sums = 712fb54f23ef0c9b832630fbf0e56ce4f512fc7e32ebdc2cd03164c20ac50d8f5546baa099a630a4499460e8f142c37bc155aa47a4271d5095ec2d6c5a87a1c5
+ sha512sums = 101f5c3a475e3a4426f1ee961749e327be19f3d12591253bd5193aebfa6801069614f4ec0fadd229cef1cfb131fd02bf604215f92dd40ebd1bc565ad226a51ad
pkgname = scratch2
diff --git a/.gitignore b/.gitignore
index f3d601b489fa..e67163d21c32 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,8 +1,10 @@
-.gitignore
-src
-src/*
-Scratch-*.air
-scratch2-*.pkg.tar.xz
-pkg
-pkg/*
-update-scratch.sh
+*
+!.gitignore
+
+!PKGBUILD
+!.SRCINFO
+
+!scratch2
+!scratch2.desktop
+!scratch2.xml
+!scratchLocalData.sol
diff --git a/PKGBUILD b/PKGBUILD
index 1969d9dae417..619368308ed4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,35 @@
# Maintainer: Amiad Bareli <amiad@hatul.info>
-
+# Contributor: relrel <relrelbachar@gmail.com>
pkgname=scratch2
-_ver=458.0.1
+_ver=461
pkgver="2.0.$_ver"
pkgrel=1
-pkgdesc="With Scratch, you can program your own interactive stories, games, and animations"
+pkgdesc="Create stories, games, and animations, share with others around the world"
arch=('any')
-url="https://scratch.mit.edu"
+url="https://scratch.mit.edu/"
license=('GPL')
-depends=('adobe-air' 'libxt' 'libxtst' 'alsa-lib')
-depends_x86_64+=('lib32-libxt' 'lib32-libxtst' 'lib32-alsa-lib')
-makedepends=('unzip')
-source=("https://download.scratch.mit.edu/scratch2download/sa/Scratch-$_ver.air" "$pkgname.desktop" "$pkgname.png" "$pkgname.xml" "x-$pkgname-project.png")
-sha1sums=('c5c9c19fb1ac57ecb7d03e4ad0d663a77e8e396c'
- '24d3849d3e38836b0b116a2e620a173f1770f13b'
- 'bfca77daa1a9079f2197d98509ca4a33b3246df1'
- '2d45707fd12c709e21fa74b85f6c7b7dfe0d47a2'
- '211b6b6ca9e987327632446f1bb15908babbcfae')
+depends=(adobe-air-sdk libxt libxtst alsa-lib)
+depends_x86_64+=(lib32-libxt lib32-libxtst lib32-alsa-lib)
+makedepends=(unzip)
+source=("https://scratch.mit.edu/scratchr2/static/sa/Scratch-$_ver.air" "$pkgname" "$pkgname.desktop" "$pkgname.xml" "scratchLocalData.sol")
+sha512sums=('cc0d98bcc90540a5b913941f57f21e87ea1bb4468260a2cb66c9688a9c25bbe4081ace6370fd2d9f66cfc8877ca5664de1e7efede7afdce004af840b71bbc46f'
+ '378551bee811e16a1139139b78d0f4e0471c67c5e1076eaaf2e137378bc44e7e3b55788fe58681da44ea8d359c6ce343f0729b2aa80dbbbd695954c3efb1515a'
+ 'e32fd12f4fbb35fa7c60d658a83d0186424c404a89064bc16f1c7df501bc325e77bdfa2f9fb291ccdd42bd4ca96fb8c51b282194d058f2b7e25b552c86f34b0f'
+ '712fb54f23ef0c9b832630fbf0e56ce4f512fc7e32ebdc2cd03164c20ac50d8f5546baa099a630a4499460e8f142c37bc155aa47a4271d5095ec2d6c5a87a1c5'
+ '101f5c3a475e3a4426f1ee961749e327be19f3d12591253bd5193aebfa6801069614f4ec0fadd229cef1cfb131fd02bf604215f92dd40ebd1bc565ad226a51ad')
noextract=("Scratch-$_ver.air")
package() {
- mkdir $srcdir/$pkgname
- unzip Scratch-$_ver.air -d $srcdir/$pkgname
-
- install -dm 755 $pkgdir/opt/airapps/
- cp -r $srcdir/$pkgname $pkgdir/opt/airapps/$pkgname
- chmod -R 755 $pkgdir/opt/airapps/$pkgname
+ mkdir -p "$pkgdir/opt/airapps/$pkgname/"
+ unzip "Scratch-$_ver.air" -d "$pkgdir/opt/airapps/$pkgname/"
+ install -Dm644 -t "$pkgdir/opt/airapps/$pkgname/" "$srcdir/scratchLocalData.sol"
- install -dm 755 $pkgdir/usr/bin
- echo "#!/bin/bash" >> $pkgdir/usr/bin/$pkgname
- echo "/opt/adobe-air-sdk/bin/adl -nodebug /opt/airapps/$pkgname/META-INF/AIR/application.xml /opt/airapps/$pkgname/ -- \"\$1\"" >> $pkgdir/usr/bin/$pkgname
- chmod 755 $pkgdir/usr/bin/$pkgname
+ install -Dm755 -t "$pkgdir/usr/bin/" "$srcdir/$pkgname"
+ install -Dm644 -t "$pkgdir/usr/share/applications/" "$srcdir/$pkgname.desktop"
+ install -Dm644 -t "$pkgdir/usr/share/mime/packages/" "$srcdir/$pkgname.xml"
- install -Dm 644 "$pkgname.desktop" $pkgdir/usr/share/applications/$pkgname.desktop
- install -Dm 644 "$pkgname.xml" $pkgdir/usr/share/mime/packages/$pkgname.xml
- install -Dm 644 "$pkgname.png" $pkgdir/usr/share/pixmaps/$pkgname-editor.png
- install -Dm 644 "x-$pkgname-project.png" $pkgdir/usr/share/pixmaps/x-$pkgname-project.png
+ for i in 16 32 48 128; do
+ install -Dm644 "$pkgdir/opt/airapps/$pkgname/icons/AppIcon$i.png" "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/$pkgname.png"
+ install -Dm644 "$pkgdir/opt/airapps/$pkgname/icons/ProjectIcon$i.png" "$pkgdir/usr/share/icons/hicolor/${i}x${i}/mimetypes/x-$pkgname-project.png"
+ done
}
diff --git a/scratch2 b/scratch2
new file mode 100755
index 000000000000..d820025d8f48
--- /dev/null
+++ b/scratch2
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+sol="$HOME/.appdata/edu.media.mit.Scratch2Editor/Local Store/#SharedObjects/Scratch.swf/scratchLocalData.sol"
+[ -f "$sol" ] || cp /opt/airapps/scratch2/scratchLocalData.sol "$sol"
+
+/opt/adobe-air-sdk/bin/adl -nodebug /opt/airapps/scratch2/META-INF/AIR/application.xml /opt/airapps/scratch2/ -- "$@"
diff --git a/scratch2.desktop b/scratch2.desktop
index b95af4e51993..3b56b24325b1 100644
--- a/scratch2.desktop
+++ b/scratch2.desktop
@@ -1,9 +1,9 @@
[Desktop Entry]
+Type=Application
Name=Scratch 2.0
-Comment=You can program your own interactive stories, games, and animations
+Comment=Create stories, games, and animations, share with others around the world
Exec=scratch2 %f
+Icon=scratch2
Terminal=false
-Type=Application
-Icon=scratch2-editor
+MimeType=application/x-scratch2-project;
Categories=Development;Education;Programming;
-MimeType=application/x-scratch2-project
diff --git a/scratch2.png b/scratch2.png
deleted file mode 100644
index efb1cf53a3d8..000000000000
--- a/scratch2.png
+++ /dev/null
Binary files differ
diff --git a/scratch2.xml b/scratch2.xml
index af1d640ca991..fc661ac1f0ea 100644
--- a/scratch2.xml
+++ b/scratch2.xml
@@ -1,8 +1,9 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
- <mime-type type="application/x-scratch2-project">
- <comment>Scratch 2.0 project file</comment>
- <generic-icon name="x-scratch2-project"/>
- <glob pattern="*.sb2"/>
- </mime-type>
-</mime-info>
+<?xml version="1.0"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="application/x-scratch2-project">
+ <comment>Scratch 2.0 Project File</comment>
+ <icon name="x-scratch2-project"/>
+ <glob-deleteall/>
+ <glob pattern="*.sb2"/>
+ </mime-type>
+</mime-info>
diff --git a/scratchLocalData.sol b/scratchLocalData.sol
new file mode 100644
index 000000000000..48c415897ef2
--- /dev/null
+++ b/scratchLocalData.sol
Binary files differ
diff --git a/x-scratch2-project.png b/x-scratch2-project.png
deleted file mode 100644
index 668883e5b973..000000000000
--- a/x-scratch2-project.png
+++ /dev/null
Binary files differ